Tally: some text fields are being ignored

  • setup Tally connection with Google Doc
  • added {{tags}} to template

Form fields are being mapped successfully. Scenario test runs without a glitch, but some random fields do not make it onto the generated Doc. Their designated tags remain empty despite there being data. Those are normal text fields (no multi-select, no drop-downs).
Gone around the houses to figure out why.

  • Tried changing field name
  • Tried changing tag names
  • looked for commonalities between those fields vs. others - nothing

Tally itself picks up these fields without a problem. Tally also saves these fields in Google Sheet.
They are only being ignored by MAKE:

  • Tested the same with connecting Email (send Email = email is received but those same text fields are being ignored)
  • Tested with Gmail via Google Workspace (email is received fine, yet again without those fields)

Am I missing something?

Welcome to the Make community!

1. Screenshots of module fields and filters

Please share screenshots of relevant module fields and filters in question? It would really help other community members to see what you’re looking at.

You can upload images here using the Upload icon in the text editor:
Screenshot_2023-10-07_111039

2. Scenario blueprint

Please export the scenario blueprint file to allow others to view the mappings and settings. At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.

Screenshot_2023-08-24_230826
(Note: Exporting your scenario will not include private information or keys to your connections)

Uploading it here will look like this:

blueprint.json (12.34 KB)

3. And most importantly, Output bundles

Please provide the output bundles of the modules by running the scenario, then click the white speech bubble on the top-right of each module, save the contents as a text file, and upload it here into this discussion thread:
Screenshot_2023-10-06_141025

Providing the output bundles will allow others to replicate what is going on in the scenario even if they do not use the external service.

Following these steps will allow others to assist you here. Thanks!

2 Likes

Thanks for these hints, Sam!

So, here’s what I see when I associate the fields:


(the fields with issues are highlighted)

… and here’s the Google Doc template with the relevant tags:

Now, since you asked me to download the Blueprint, I did and took a quick look and noticed that all the problematic field names and in an obsolete/invisible line break “\n” (starts line 139) - all other fields don’t have this.
blueprint.json (68.9 KB)

I’m not quite sure where they come from and what’s the best way to remove these (and where?). Any ideas would be hugely appreciated.

Hey @nadworks, I haven’t looked at your blueprint but I experienced this in a few instances.

a) the answer might just be empty (question is not required in Tally) thus nothing to put into the variable in Gdocs. You might want to add „ifempty(xy, {{emptystring}})
b) you are using the Tally variables „Fields“ and not „Fields by Id“. The „fields by Id“ are mapped by using an ID and do not change if you happen to change the copy. Whereas the „fields“ are created by matching the question‘s title. So if you happen to create a form using
„first name“ → put that into GDocs
Now you change the question to „what’s you first name?“ → the variable „first name“ will now be empty. That‘s why I’d advice to use the „fields by id“.

3 Likes