Trying to Pass Multiple Airtable Record Attachments to PDF.CO to merge into one file & save to google drive? Only Outputs first PDF file

New to Make, so this is my first scenario. So far I’ve been able to figure out the rest of the automation I’m trying to create which is as follows (all pulling from airtable and saving to dropbox):

  1. Click a button in one airtable table to trigger a webhook (works)
  2. Receive the webhook in make and pull the rest of the record field data from the record the button was clicked in (works)
  3. Route this info off and use the name of the record to create a new folder in dropbox (works)
  4. Delay on remaining steps to allow the folder to create (works)
  5. Use the date field data from the get record to search another airtable table for records that fit the date range and return those records (works)
  6. Route the search records 3 ways
    a) iterator - https get file - save files to dropbox new folder made in #3 (loops through the # of records searched in previous steps and downloads each attachment for each record to the dropbx folder) (works)
    b) iterator - update airtable record - links each of the searched records in table2 to the initial record in table1 where the button was clicked (works)

The one that doesn’t work:
c) Trying to use the bundles from “search records” in #6 to process into to merge however many records attachments there are (in my sample case, 5 records in airtable with one attachment each) into one single PDF and save this merged pdf into the new dropbox folder.

For whatever reason I cannot get the merge to work. I have tried a bunch of different configurations and I get PDF.CO processing 1 PDF at a time and saving each individual PDF separately (same as the https get file branch). I can get the PDF.CO to “merge” but it only grabs the first record in the bundle(s). I have it going (see screenshot) from search records → router → Array Aggregator → PDF.CO → Dropbox upload file. The output of Array Aggregator appears to be right (an array of the 5 bundles from the search record step) but then the input from PDF.CO does not match and only contains the first bundle, not the aggregated array.

Scenario layout, top 2 branches work

settings for array aggregator

output of array aggregator

settings for

input for

i think this must lie with incorrect settings on the PDF.CO where I am getting my input link URLs, but at this point I think i’ve tried every combo and it doesn’t translate to running 5ea URLs to grab the PDFs and merge them, just stalls at the first one (all URLs do contain a PDF).

Any input appreciated. This is my first time using make but other than this one issue everything else has been pretty smooth.

The setup you have provides looks good, my only concern is the last Module for Seems like the Array that you are passing is not correctly formatted and is only getting a single URL.

Try this,

{{join(map("array"; ""); ",")}}

Not sure, if it works on the first try, but give it a try preferably in a Set a Variable Module and see if you get a comma-separated URL after applying the above formula, the array denotes the Array Aggregator result.

1 Like