Unable to update standard fields in Salesforce

Hi, I’m working on a scenario where I want to update account record’s standard fields in salesforce using google form. Well, when I run the flow, it update the custom fields on account record’s with no issues. But When I try to update Standard fields like FirstName, LastName, BillingStreet, BillingCity, BillingCountry it’s not working. As you can see in the screenshot it only shows custom field value, not standard field, and I don’t understand why. I would be grateful if someone can help me with this.

This is weird still I would recommend you to try Get Record Module and enter this record id * Record ID: 0012w00001MVIyEAAX

Check if this record updated with all the values you mapped from Google form.

Also there may be a case that output showing only the updated fields and not all fields


Are you certain that the values from the On-Boarding form that you’re mapping into the Standard fields are non-empty?

Can you show a screenshot of the “speech bubble” for the output from the On-Boarding Form?


@DavidGurr_Make @Manish_GrowwStacks
Please check the below screenshots. I got the data successfully from google form. And in 2nd/3rd image you can see the standard fields of salesforce like address city/street which I’ve mapped with google form fields like city/street/firstname/lastname & all. But when I run the flow it only update custom field (refer last image) i.e., “MRP Price” I’m not able to understand what’s the issue here.

Ah, I see the problem.

If you look at the mapping of (for example) the Last Name field in the Salesforce module, you’ll see that it ends with … Answers[ ].value

The ‘[ ]’ indicates that the Answers object is an array - and if you look at the output of the Google Forms module, you’ll see that it says (Array) next to answers.

In all your cases there is just a single element in that array - but in theory there could be more.

If you’re certain that this case there will only ever be one element in those arrays, you can simply put a “1” between the square brackets in every mapped field that includes square brackets. That will retrieve the first element of that array.

If there might be more than one element, then you’d need to decide how to handle that with a restructuring of your scenario.


Actually the issue was with mapping, if you take the look at the mapping it’s “Answers.Address: Pincode.Grade.Feedback.textAnswers.answer:value” which is wrong “Answers.Address: Pincode.textAnswers.answer:value”.
So I needed to get textanswer value not the grade.feedback.textanswer. I tested it & it’s working fine.
Thanks for the support.


Good to hear! Thanks for posting the outcome.

1 Like

Hey there @Swapnil :wave:,

Just thought I might step in and pat you on the back for the great job you did while figuring out this problem. I’m thrilled to see you were able to learn more about the product and come up with a solution! :clap:
Also thank you for stepping back into the community and sharing your solution with us. We greatly appreciate that.
Keep up the amazing work!