Unsplash module not connecting to API

I have created access keys and secret keys on Unsplash and used to connect to the Unsplash module but I get the following error

An error has occurred
The redirect uri included is not valid.

Any idea what I’m missing?

Can you provide us a run-through of the steps you took to set it up? What is the redirect uri you used?


Hi @samliew,

I realised that I didn’t change the URI on Unsplash but even after I did to

and tried to “Authorize” and press continue for my name, I now get a “Bad Request”.

1 Like

Hi, same here,
I followed the tutorial step by step and I always get the following message:

“Client authentication failed due to unknown client, no client authentication included, or unsupported authentication method.”

I tried every combination with secret key/API key/ Client ID
I also tried to replace “integromat” by “make” in the link “https://www.integromat.com/oauth/cb/unsplash

Nothing worked :man_shrugging:

same here
nobody has submitted a ticket ?

For quicker assistance with bugs and technical problems, you may want to contact support directly. They respond very quickly and update you frequently on the status of their investigation.

Hope you can share the resolution with us if you manage to solve this problem!


Ok @vincentywt @Stephane_Frances

the steps are

On https://unsplash.com/
You need to click on Authorize
https://www.integromat.com/oauth/cb/unsplash (Authorize)

Step 2
VERY IMPORTANT don’t click on the login button ie “continue as [your-nickname]”

Step 3
Go to Make and follow step 4 of the tutorial (ie create the connection by pasting your client id and secret id)

Step 4
Now you can click on the button “continue as [your-nickname]”


Thanks for sharing :slightly_smiling_face:

1 Like

hello emile, it doesn’t work for me. i did it exactly as you described and always get an error message. is there another trick or has something changed? Thank you very much!

Hi @WDGrimm, Welcome to the Make community!

I have just set-up Unsplash for the first time just to test it out, and it is definitely working as described in the Help Center article.

Perhaps you can do a screen recording of how you are setting it up?

Some things to check:

  • Did you grant all scopes?
  • Did you insert the correct Redirect URI?
  • Did you copy the Access Key and Secret Key, into the Client ID and Client Secret fields respectively?


Hey @solution Guru,
I did them all exactly the same way.
thanks for that…

It is of course somewhat misleading in “Make” if the “Client ID” input field actually has to contain the access key. I thought you were mistaken, but that’s exactly how it should be.

Incidentally, the Make docs also contain a misleading statement

please change the field name in the app (see screenshot)
Thank you in any case for your quick support!

No problem, glad I could help!

For issues with the Make documentation, directly contacting support can often lead to a faster resolution.

You can open a new ticket, or if you are unable to login for some reason, you also can reach support using the contact form on the website.