Values being added into new Smartsheet row has apostrophe

Hello smart people!

Wondering if you can help me solve this.

One of my modules is adding a new row to Smartsheet.

Even if I hard code a number into the value, it’s adding an apostrophe into the cell.

So instead of a number like 100 going into the cell, it’s going in as '100.

This doesn’t seem to be happening when I’m updating a cell, just on adding a new row.

Any ideas on how to resolve?

Thank you for your suggestions and help!

Hi. Try add an replace function to remove the apostrophe in the field mapped.

Thanks, Helio!
If you have questions reach out :wink:

1 Like

Thank you for the suggestion. I actually tried the parse number thing too and there is no apostrophe at the Make level for the value before it goes into Smartsheet, but when it does go into Smartsheet, it adds the apostrophe.

I had that problem too. Make recongnises it as a number but Smartsheet sees it as text, and the parse idea didn’t work for me either,

The only way I got around it was to have a helper column in Smartsheet that make puts data into then I had a value() function in the original column that converted the helper to a number.

Sorry its a bit of work around but it worked for me in my use cases.

1 Like