Webflow API V2? Update with Make.com Connection


I have a scenario with api calls to webflow up and running since 5 months and never had problems. A few days ago i noticed that CMS Items won’t get deleted (like they should) anymore, but will only be set to draft.

That made no difference in the end-product, so I first did not care.

But now i get Errors all the time when I try to delete CMS Items with the make integration. I first thought there must have been an update anywhere, but I cannot seem to find where the error came from.

Here is the module, where i use API call as according to the webflow documentation: Delete Collection Item.

The first error i got was: The operation failed with an error. [missing_scopes] undefined
So i reconnect webflow to make, which resolved the scope issue.

Now the error is: The operation failed with an error. [400] ValidationError: Invalid request body

I unfortunately cannot share more details on other parts of the automation, but all of these work fine and the variable input data (which is just Item ID) is 100% correct data. So i think that does not matter anyways.

Best regards!

Webflow v2 modules uses OAuth 2.0, which involves scopes. You’ll need to set the connection up in the Project Settings first with all the scopes.


@samliew I have make shown under the connect Apps of my project settings in webflow:

I also reconnected Make to make sure i set up the scopes correctly but while setting up make integration in webflow you can only choose which workspaces/site make has access to. So i definitly could not mess this up, right?

In the linked documentation, the endpoint is


but in your Make an API Call module, your URL is


I also tried this code, which did not work either. Also tried it withouth the first /


No success either…

Hi there :wave:

Same problem as @stoesselleon with the module “Make an API call” and using the endpoint " Delete Collection Item (Live)"

Although the API doc mentions the endpoint https://api.webflow.com/v2/collections/{collection_id}/items/{item_id}/live
This is not possible in the module which accept only a path relative to https://api.webflow.com/beta as mentioned in red in the module.
If I set /v2/collections/{collection_id}/items/{item_id}/live I have got an ERROR 500 :red_circle:
If I set /collections/{collection_id}/items/{item_id}/live this is ok without ERROR 500 :white_check_mark:
(I did some tests with the method GET to check the access to the endpoint.)

When using the method DELETE (which is necessary regarding the doc), I have an ERROR 400 “Invalid Request body” and I don’t understand what could be the problem.

Hey @stoesselleon :wave:

The V2 Beta API doc explains:

:arrow_right: Try the settings below which work for my scenario.

In the “Make an API call” module:


At this step, the item is set to “draft” (despite the DELETE method).

Then add a “Delete an item module” targetting your item ID.

Hope this will work for you too.


Thank you for this replay. Having an Empty Body actually solved it. Was kind of frustrating to figure out, because i never got the missing body error myself.

Thank you so much!


Thank you @Vianney! :clap: