WooCommerce Webhook not accepting Data

I have a woocommerce site that has subscriptions and it has a function to fire a webhook when a subscription is created. All of this works without any issue.

When I test through a place like webhook.site everything comes though in a JSON body. Nothing happens here at make and I’m not sure why it’s not coming in. I have tried creating my own data structure, I have tried a couple of other things but I just cannot get the webhook to process the data to Google sheets or even acknowledge that it’s getting new data.

Thanks in advance for any help on this.

May peace be upon you @StandardWP

Can you please share the scenario blueprint and also details on how you have connected Make.com with woo commerce?


@ Automate_with_Rezwan
I connected with Woo by creating the Webhook in woocommerce settings and following the webhook guidelines here on Make. It connects fine and accepts the webhook id, but then no information further.

I had two modules, Custom Webhook, and Google sheets add a row.

I uploaded the blueprint and removed some personal data.

blueprint.json (37.1 KB)

1 Like

@StandardWP why aren’t you using the official Woocommerce module ( New event/Watch Orders )


Because I’m not trying to pull orders. I’m specifically trying to pull subscriptions from the Yith Subscription plugin as they are created, updated and cancelled. I haven’t gotten past the created part yet to do the rest however.

The site is firing the webhooks, and they get received at webhook.site but not here.

Here is the beginning of the hook. I left out the rest due to sensitive info, but it’s all there.

“id”: 4798,
“parent_id”: 0,
“status”: “completed”,
“currency”: “USD”,
“version”: “8.3.1”,
“prices_include_tax”: false,
“date_created”: “2023-12-09T18:44:45”,
“date_modified”: “2023-12-09T18:44:46”,
“discount_total”: “20.00”,
“discount_tax”: “1.20”,
“shipping_total”: “0.00”,
“shipping_tax”: “0.00”,
“cart_tax”: “0.00”,
“total”: “0.00”,
“total_tax”: “0.00”,
“customer_id”: 1,
“order_key”: “wc_order_mP9FNq4HCNtz5”,
“billing”: {

Everything seems to be there, Make doesn’t seem to be mapping it.

Welcome to the Make community!

You can manually start a “Redetermine data structure” and trigger a webhook call from Yith.


Or ensure your webhook “JSON pass-through” is set to “No”, and “Generate” a data structure from a sample JSON request.

1 Like

@Automate_with_Rezwan which settings would you like? I’d rather not a call.

@samliew Thanks for the reply.

I tried the settings as above, and even pasted a sample json webhook that I get at webhook.site in to learn the structure as when I send one while it’s waiting it doesn’t acknowledge that one is coming in. Am I just being impatient? I do know that when it gathers the information from my sample it takes a while, I just can’t tell if it’s doing anything when I trigger a sample request from yith.

After I had put in the sample and it had the structure, I tried to send another hook from the site and nothing happened. Not sure what I’m missing here.

Is there any place that I can check that the webhook module is even receiving the hook? I don’t even think it is, and I know it’s going out as I have it sending to webhook.site as well.

Thanks again.

From your screenshots, I can’t tell if your scenario has been turned on. Can you check if it is?

You can view previous scenario executions in the History tab.


Yes it was turned on and there were no executions that I could tell. I thought that was the spot to watch, was just hoping that there was another one.

I followed the webhooks guides to get the connection and the secret back to my site, then I turned everything on and did tons of tests. None of which made it to make, as mentioned I had the webhook going to two different places. One got them, Make did not. I want to say that I had over 25 tests all using a slightly different tweak to see if something would make the trigger work but alas nothing.

Thanks again. @samliew