Wordpress integration

Hi, After a few months of inactivity I reenabled my WP integration. Unfortunately “Create Post” module does not create the post. The connection is fine and it can GET data from WP. I get no error, simply the output is empty, and no post is created (a CPT in this case, but I also tried with regular post).
Screenshot 2023-07-24 at 16.20.10

Siteground says all is fine on the server’s side. Does anyone have an idea why this could be?
Thank you,

There’s a 1001 different things in WordPress that can conflict with proper running of the API (that’s a WordPress API issue, not specifically a Make issue).

First key steps are:

  • Turn off all Plugins apart from the Make Plugin. If that fixes it, turn them back on one by one until you find the culprit.
  • Advanced Access Manager (AAM) is a common cause as it has many features that can affect the REST API. If that’s the cause, try turning off all features within AAM and then turning them back on one by one.
  • Turn off Permalink processing (back to “Simple”)

Hi David, I have tried all that you suggested but the issue persists unfortunately.
I would like to try and create a new connection with a different API key. Do you know by any chance how I can get the plugin to produce a new one?

I have already deactivated/deleted etc.
The integration worked seamlessly when the website was not published.
Many thanks!

Update: following investigations, the issue was due to redirects on the server side.
If anyone encounters the same issue, try connecting with https://www. instead of https://

This worked for us, and now we can POST (and not just GET).
Thank you,


Hello @giupi welcome to the community :wave:

I just wanted to quickly jump in and say awesome work getting to the bottom of this :clap:

Also, thank you so much for stepping back here and sharing what you’ve learned with the community. We genuinely value and appreciate it :blush:


Hello, Have any of you tried another solution for this problem because I’m afraid the solution won’t work on my side?