403 error code: rest_cannot_create

I am getting the following error in the WordPress create post module:

[403] Sorry, you are not allowed to create posts as this user. (error code: rest_cannot_create)

I have confirmed the REST API Base URL with my host. It is enabled and correct. I have also confirmed it (I think) using Postman.
I have the Make.com plugin added to my WordPress site and have checked every box for posts, comments, users and terms in the Custom API Fields section.

Thank you for any guidance you can provide!

Should add that I have installed the DevTool Chrome extension but I can’t really make sense of it.

A 403 status points to a Forbidden error. It could be that you have authenticated successfully, but the user you are authenticated with has insufficient rights to create posts.

Something else to check is if the outgoing IP address of Make is blocked, and therefore cannot access the resource in WP.

Henk
Make Level 5 Expert & Partner

1 Like

I appreciate the reply and information. I used the Admin account when I installed the plugin and pulled the API key. I assume it is that same users, which has all rights, that I am authenticating as. As for the IP address - I am using the same desktop with presumably the same IP address that I used to install the plugin, pull the API Key and regularly access WordPress without issue. There are no firewalls on my desktop or anything else on my host that is blocking IP’s.

Can you walk me through how to use the DevTool plugin to get more detail? Maybe I can find some hints there that will help? Hitting Ctrl-Shift-I takes me to this screen (see attached). It does not resemble what I should see according to the screenshot on this page - https://www.make.com/en/help/scenarios/make-devtool. Maybe I am doing something wrong? Thank you again!

Mind you that the IP address of your device does not matter, Make sends the request from their servers. If possible, you should whitelist the IP addresses for the region your Make account is in: https://www.make.com/en/help/connections/allowing-connections-to-and-from-make-ip-addresses

So your own IP address is different from Make’s, which could be the cause of your issues.

As for the Integromat DevTool, it is best to use your developer tools in horizontal mode. You will find the ‘integromat’ (Make was formerly called Integromat) tab like shown below. This will give you a list of options, including access to the requests that are sent from, and to, Make. It looks like this:

This is a more in-depth explaination of the extension: https://www.youtube.com/watch?v=K6Mz6aERWL4

1 Like

Got it! I doubt my host would be blocking any specific IP address, but I will ask them to whitelist the ones you referenced in the link provided from us1.make.com. I will also watch the video and hope to get this resolved. Thank you again for the support. I will update after the IP addresses have been whitelisted and I have watched the video.

Just spoke to my hosting company - none of the listed IP addresses are blocked. Hoping to find some clues in the DevTool now. The video was very helpful - thank you! I see the following:

In LiveStream
{
“type”: “error”,
“array”: “[403] Sorry, you are not allowed to create posts as this user. (error code: rest_cannot_create)”,
“_engineData”: {
“calledAt”: “Not available”
}
}

In Scenario Debugger
The only thing that caught my eye is the URL - https://thepeachbasket.net/wp-json/wp/v2/posts

That URL might be right, but I used https://thepeachbasket.net/wp-json as the REST API base url field.

Thank you again for any information you can provide. We have a user with all permissions, no blocking of IP addresses but with an inability to create posts.

Just checking in to see if anyone has any other ideas? For now I am moving the content to Google Docs then copy/pasting into WordPress. I would much rather this be automated all the way through to WP though. Again, thank you for any help/guidance anyone can provide!