WordPress plugin: TypeError in editor when custom 'theme' taxonomy enabled in Custom API Fields settings

  1. We have a WordPress site with custom post types, and a couple custom taxonomies for it. We can edit these posts just fine.
  2. We installed the Make/Integromat plugin on site (since 1.5.4). We activate it. Seems to work fine, we can even run some scenarios.
  3. Whenever we try to include one of these custom taxonomies (‘theme_tax’), the edit page loads, and when it loads the taxonomies an error appears and blocks the load.
  4. If we deactivate the Make/Integromat plugin or uncheck ‘theme_tax’ (in Custom API Fields settings), everything works fine again, no errors.
  5. It only seems to occur for some users, not all users (for example, some editors can edit just fine)
  6. It only seems to occur for post types which make use of/load this specific custom taxonomy.
  7. The editor also crashes when creating a new item of those post types

Make plugin version:
1.5.8 (but issue also occurs on any version below, as we’ve tested)

WordPress version 6.1.3 (but also occurs on 6.2.2, as we’ve tested)

We’ve already checked for plugin conflicts by disabling all plugins (except Advanced Custom Fields 6.1.6 (as this is core/mu-plugin), and the issue still occurs.

Screenshot of the editor crashing:

The error:

TypeError: Cannot read properties of null (reading 'indexOf')
    at n (https:/siteurl.com/wp-includes/js/dist/editor.min.js?ver=1fb5fcf129627da4939e:19:106536)
    at https:/siteurl.com/wp-includes/js/dist/editor.min.js?ver=1fb5fcf129627da4939e:19:106654
    at Array.sort (<anonymous>)
    at https:/siteurl.com/wp-includes/js/dist/editor.min.js?ver=1fb5fcf129627da4939e:19:106632
    at https:/siteurl.com/wp-includes/js/dist/editor.min.js?ver=1fb5fcf129627da4939e:19:106705
    at Object.useMemo (https:/siteurl.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=18.2.0:10:115389)
    at e.useMemo (https:/siteurl.com/wp-includes/js/dist/vendor/react.min.js?ver=18.2.0:10:9875)
    at Vi (https:/siteurl.com/wp-includes/js/dist/editor.min.js?ver=1fb5fcf129627da4939e:19:106498)
    at kt (https:/siteurl.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=18.2.0:10:47633)
    at js (https:/siteurl.com/wp-includes/js/dist/vendor/react-dom.min.js?ver=18.2.0:10:120746)

It seems to be a somewhat similar issue as Make (Integromat) Wordpress plugin breaking the website, despite the error being different.
Any ideas about the cause?

@marlou thanks for the details. This looks like it might be a bug on our side, so I’ve raised a ticket for our developers to look into it.

Thanks for bringing it to our attention!


I experience the same issue.

When will this problem be resolved?

@Tom3008 I’m sorry to hear you’re running into the same problem.

I can confirm this is now being worked on by our development team. I don’t yet have an ETA for a fix, but I’ll post in this thread when I hear more.

1 Like

@DavidGurr_Make Is there a workaround? Because right now I cannot create posts with custom taxonomies on my WP-page. When custom taxonemies is not activated in the make plugin, they do not show in the content editor either.

I think the only workaround is to disable the theme in the Make plugin (item #4 in the OP’s post above).


@DavidGurr_Make Where is the theme_tax option? I cannot find it in my Make plugin in Custom API Fields settings…

That’s the name of the OP’s custom taxonomy. You’d uncheck your own custom taxonomies.

@DavidGurr_Make Okay, as that automatically hides the taxonomy picker from the post editor (for some reason), that is not an option….

Is there any other way to connect one Wordpress blog to another?

@marlou @Tom3008 We have been investigating this and may have found the solution.

This problem seems to occur when using identical names for custom taxonomies and custom post fields. If that’s true in your case, please try changing the name of either the custom taxonomy or the custom post field and let me know if that solves the problem.


@DavidGurr_Make Thanks! Deactivating the taxonomies with the same name worked.

Now, however, when I try to edit name of advanced custom fields and add new ones, the changes do not show in the make plugin or in make.

I have tried to publish new posts with the fields in use and reinstalling the plugin. Nothing works. Do you have a fix for that as well?

I am so close to creating the perfect make-journey!

Thanks so far,

Hi @Tom3008

If the custom fields are used by multiple post types, they appear under “Universal metas” group.

We’ve noticed that sometimes, they might be displayed under the wrong post type, which seems like a bug. We’ll be investigating that one in due course.