Wordpress Custom post type

I’m trying to use the “WordPress Create a post” moduel to post new content on my website. But in the “Type” drop-down I can only find posts, pages, etc, etc. But I want to choose a custom post type that I have on my website called “portfolio”.

Does anyone have any idea how I go about this?
Any help would be appreciated because I’m totally clueless about how to proceed here.
Thank you,

1 Like

have you tried toggling to map and entering the post type name in manually?


After you’ve installed the integromat plugin, you’ll need to enable the custom post type and any fields you’d like accessible via Make.


Sadly, I have tried this with no luck

I have done this now but it didn’t change anything.
It doesn’t show up in the drop-down, and when I try using the map function and entering it manually I get a
“[404] No route was found matching the URL and request method. (error code: rest_no_route)”

When you created the cpt, did you enable rest api for it? It was an option on the plug-in I used

The post type is part of the theme I use. And I’m pretty sure it has the rest api enabled for it

Did you solve the problem?

I created a post type manually on my wp-site and it worked perfectely.

In october (a short whlie after your problem occured) I importet a perfectely working scenario into another make-account of a client.

Since that date I try to make it work again, but can’t.

I asked the support of make because I even couldn’t set up the connection without a 403-message.

They said, it’s something with the route and I have to ask the host.
The host told me, that the path is wrong, and that I should now use
https://domain.com/wp-json but

… although before the first path worked perfectely with another scenario in my own account. :woman_shrugging:t3:

With this information at least it was possible to save the scenario after the import, because I was able to connect it without an error message.

I still have this error message, when I try to update data in that custom post-type and want to set a certain category and/ or tag.

Always looks like that:

The first modules run without any problem. The error message looks like that:

And it seems to find the custom post type that I filled in manually mapping the content.

But not the category and tags :pensive:

I tried to map the content and write the existing post type, category and tag into it. Didn’t work.
I also watched for the tag-id of the category or tag in the adress line of the browser and filled in that number. Didn’t work.

So, one month went by and nothing happend…

Still looking for a solution!

Has anyone an idea?


1 Like

Hi, I am joining the topic because I face the same issue.
I would like to create a post on my Facebook Page whenever I publish a new recipe on my blog. The problem is that I too cannot find the right post type I need.

I solved that problem adding custom post types to the rest API

 * Add REST API support to an already registered post type.
add_filter( 'register_post_type_args', 'my_post_type_args', 10, 2 );

function my_post_type_args( $args, $post_type ) {

    if ( 'book' === $post_type ) {
        $args['show_in_rest'] = true;

        // Optionally customize the rest_base or rest_controller_class
        $args['rest_base']             = 'books';
        $args['rest_controller_class'] = 'WP_REST_Posts_Controller';

    return $args;

replace "books" for you custom post type

Hey there @Jonas :wave:

did you have a minute to check out the suggestions that appeared here? If yes could you give us an update on how’s the problem looking now?

If you fixed it, please mark the most helpful suggestion as a solution.

Thank you :seedling: