Wordpress - Statuts code error : 401

Good morning,

I am looking to use MAKE to share articles from my site on different social networks.
I installed the extension on my site but when I try to connect with wordpress on make I get a 401 error.

On my site I tried to deactivate iThemes Security and Wordfence but I still have the error.

I found a similar thread on the forum but it doesn’t seem to be resolved. WordPress connection issue - Nerd-Zone - Make Community
I contacted support but haven’t heard back yet.
My site is hosted by IONOS.

Thank you for your help

Hey @Valentin_Hbt, sorry to hear you’re having problems!

401 errors with WordPress are a tricky area, and often not anything to do with Make - this post on WPBeginner covers a lot of the potential causes.

If none of the suggestions help, then I’d recommend trying to access the WordPress API using Postman. If that also doesn’t work then it strongly suggests it’s a problem on the WordPress side.


Thank you for your reply.
I had found these sites that refer to the 401 error but the error being sent to make I didn’t think they were related.
I did some operations like disabling Wordfence and itheme security but it still returns the 401 error.

I am going to contact my host, what should I ask them?

I just did a test with Postman and itheme security activity and here is the result:

When I deactivate itheme I have a result on postman:

But when I connect the wordpress I have a 404 error

404 is a “path not found” error.

I would suggest double-checking the path - remember, you should be entering a base URL, not a full API endpoint URL

1 Like

ok I just have to put https://staugustin.fr/wp-json/ ?
Sorry I’m not a dev

EDIT : always a 401 error with /wp-json/ but Postman send this :

Good morning,
I had IONOS support on the phone.
When explaining the problem, the interlocutor asked me if the solution needed root host access to work.
Currently in my offer this is not the case.
thanks in advance

Looking into this further … :eyes:

1 Like

@Valentin_Hbt can you confirm that you’ve installed the Make plugin for WordPress?

If you have, then please try using Postman to GET a result from the following endpoint (this is the same endpoint that’s used to validate your Make connection to WordPress):


Under the Headers tab in Postman you’ll need to add a Header called Authorization with the value:

Bearer: <Your API key>

(change <Your API key> for your key - don’t include the <> brackets)

1 Like

Good morning,
Thank you for your reply.
The Make extension is well installed on my site.
What doesn’t work is the connection.

I did the test on postman and here is the result :

Silly question, but I have to ask … you’re 100% sure that the API key you’ve entered is correct?


Apologies, the header info I gave you for authentication was incorrect!

Try Postman again, removing the Authentication header and adding header called iwc-api-key with just the value of your API Key.


Like that ? :

That’s it … but I notice you have a trailing “.” at the end of your API key that’s not show in the Make plugin screenshot you included earlier.

1 Like

Good morning,

Thank you for your reply.
I redid without the “.” but the result is the same.

If you’re 100% certain that the API key is correct then the fact that this is happening with Postman as well as with Make suggests that it’s something in your hosting provider’s configuration. Some WordPress hosting providers block any unexpected headers, which might cause this problem.

We may be able to diagnose this further …

Could you download the log file from the Make plugin page? As an extra security step, send it to me as a DM rather than replying here.

1 Like

Thank you for your reply.
The key is correct, I simply copy paste from make into wordpress, nothing more.
I’m in contact with my host but technically I don’t know what to ask him.
It’s Ionos, a host that doesn’t just do wordpress.
Can you explain to me clearly what I have to ask them to unlock? Is root access required?

I looked at the side of the log file but I don’t see anything wrong.
I send it to you in PM

The line codes: 3() when requesting /wp-json/wp/v2/users/me indicates that the Make plugin hasn’t been able to find any Admin user. Which is strange, as you obviously have Admin access to install the plugin and to download the logs!

Something is interfering with the processing of the WordPress REST API. Have you disabled all other plugins? One likely suspect is the Advanced Access Manager (AAM) plugin which has wide-reaching effects on user privileges and REST API access.


Good morning,
Thank you for your reply.
I have the AAM extension but my account is full access administrator.
I will dig this with my developer.
I come back to you.
thanks again