Xero Invoice - Post attachment

Hi There,

I’m going to bed tired and with a foggy brain, hoping to wake tomorrow feeling sharp and able to solve this.

I thought, as a back up plan, I’d post here in case someone can surprise me in the morning.

Basically moving over an automation from Zapier to Make that creates an invoice (Bill) and adds an attachment. Works great in Zapier.

Creating the same in Make doesn’t have an option to add the attachment, It seems this is done after the event with an API call. I’m trying to convert a file using cloudconvert (works OK) and then add this to the Invoice.

I’m getting authorization errors and before that getting timeout errors. Everything seem to look OK but I’m not familiar with this process so probably missing something. See attached

Hope you can help

Note: the body is just the raw output from the CloudConvert download


Hey Jason - know that feeling!

In your Xero module , you have /test/ in your URL. Remove that as it’s altering the endpoint. 4XX error may be a result of that.

Also, for context, Xero had a wobbly with Make for some time recently - hopefully it’s fixed, but we got lots of 4XX errors randomly.

Finally, if neither of the above work - just a thought: Try inserting a ‘get file’ module (within https module) after CloudConvert to ensure you are actually obtaining a public URL from CloudConvert. Then map that (the retrieved file in the https module) to the attachment in Xero.

Just gonna say this - I am not a developer, I just work with them lol so they might be embarrassed at my advice :rofl:


Hey thanks Alistair,

I apricate the input. The test is the file name, I’ve tried with and without extension as in the example in the documentation


I’ve also tried with the getfile to rule out any issues with the CloudConvert download but no joy :frowning:

I’ve keep battling on and post if I crack it.

Thanks again

1 Like