[400] Unsaved transactions: Unrecognized error

I have a list of tasks in Notion and each of the task has two checkboxes that I’m checking via Notion Search Object module.

One is a trigger for running a script (that is connecting to some invoicing system, but the error keeps happening also without these steps, so I won’t be focusing on it). Marking this checkbox is starting the sequence.

And another one is for marking the task as ‘done’, so it won’t be included in the next run. I only want to run the script for tasks that have this box unchecked (so that are ‘undone’).

After the script is completed, I want to change the ‘undone’ checkbox to ‘done’ (so false to true) using Update a Database Item module, but I’m keep getting this error:

Here is the Update a Database Item module. It’s worth mentioning that the other property (Status) is updating correctly:

And here is the whole scenario:

1 Like

I’m getting this same error just in the last number of hours --maybe there is a Notion API issue?

I’ve been making the same mistakes for 9 hours without changing my Make scenarios.

Yes, this is a temporary issue with the Notion API (source: Notion developers Slack)


Hi @Simo :wave:

Thank you for updating us about this issue, hopefully it will be resolved soon :pray:

any updates on the issue ?

Have there been any resolutions or updates to address this issue?

I am having exactly the same issue. I have a scenario synchronizing data from pipedrive to notion that started crashing yesterday evening, without any changes on our side
No visible data issue in the details logs, except the [400] Unsaved transactions: Unrecognized error.

This started for me late yesterday too. I’ve filed a report with Notion as well.

I can’t find any info about updates on either Notion or Make in the last day, but it seems like one of them must have.

Hi @Simo do you have any updates on this case ? Thank you !

I don’t have any updates yet - the team writes that they are looking into this, but no resolutions or clear updates yet


I have the same issue, does any of you have a link to the notion ticket?
any workaround?

I have the same problem :frowning:

I’m having the same problem as well

The same error is occurring on Zapier.

We resolved this by removing the to-do list - [ ] in the content.

Same here. Couldnt fix it yet

Hi ! Same for me … The problem is from Notion or Make ?

Ok so I also had 2 checkbox.
I transformed one in Select and the synchronization between make and notion is now working again.

Update: Notion Status - Checkbox creation and updates down


Thank you for your update.