401 Authentication issues with OneDrive

I’m getting constant 401 errors with Onedrive, every module and every scenario…just out of nowhere.
Everything was working fine until today. No changes happened with microsoft.
If I create a new module, with a fresh new connection to microsoft, it works…ONCE. Then falls over again with 401 all over.
What is going on???

Hey @Tapaha_Robati,

Great to see your question here in the community! :slight_smile:

I just wanted to clarify that this is a community of Make users helping out and sharing knowledge. This means we don’t have access to any of your scenarios, organizations etc.
It’s therefore always best to share some screenshots so that the community can see what’s going on in your scenarios visually.

Detailed information could be provided for example by an:

  1. overview of your scenario setup (functions, mappings, variables etc.)
  2. the input area of the module you are having trouble with
  3. the output area of the module you are getting data from

Thank you!

In case you think this is not needed, please disregard this message. I have send this message by automation since you don’t have any attachments.

This is the module. Webhook that catches an email. It has the attachement in it. All it’s doing it sending it to onedrive.

I ran this scenario with fresh credentials and it worked. Then I waited for about a minute and ran it again. Then this happens.

Try re-authenticating the connection. It looks like all services are running OK at Microsoft their side.

I’ve done that quite a few times. I’ve managed to isolate it down to the OneDrive module using a site drive, and not my drive. Something is not working with the SharePoint/site access.
That said, it can read the contents fine, but just isn’t passing credentials properly anymore to download or upload to OneDrive.