Airtable is not parsing the date correctly

After upgrading to make integration for my date field is throwing up errors even though my data is right. I have noticed this only for newly created scenarios. Previous scenarios seem to be running fine. I have made a simple integration to demo this step. The inbuilt typeform integration works fine. Also, my previously configured integrations are working without errors.

I have tried contacting make support after raising a ticket. It says check email, but there is no confirmation of a ticket raised.

Check you raw call body and see if the date format matches Airtable documentation. You might have to format the date a specific way to make it work.

The question is why am I having to format this field when the other scenario is working just fine? I have never had to format date on any of my scenarios before. And direct integration through typeform works absolutely fine. This is occurring only after creating new scenarios after the upgrade to make.
The raw data format is exactly the same.
Attaching a scenario I have made before the upgrade to make. This is working just fine

I am not sure exactly why the Airtable module in Make works differently than in Integromat. The error is returned by Airtable so it looks like Make does not send the date in the right format with your current mapping.

Try to format the date like this:

The format seems to be right

@erinviegas It could be the that typeform is exporting this date as text, and Make doesn’t properly send this over. Date field types can be very tricky sometimes.

I don’t see your data or fields coming over from typeform, but before sending it to Airtable try a parseDate() to make sure its a date field:

{{parseDate(2.date; "DD-MM-YYYY HH:mm")}}

It is exporting as date and not text. Even using the Parse function does not work.

@erinviegas Can you show us how you’ve setup the airtable module?

I’ve made a video here to best try and explain the problem.
Please pardon the sniffling. I have the flu.

Hey there,

I had the same exact issue, filed a ticket with support - not helpful.

I resolved my issue when i enabled typecast (It’s the option named “Smart links”) in the airtable module. It tells airtable API to do its best to convert the string you give into the date.

Hope that helps

2 Likes

Hey @erinviegas , like @Pavel_Abaev says you can enable the “Smart links”.
It looks like this formatDate() function either has a bug or weird intention. I will escalate this to the development team to see if it can be resolved.

Wow, this worked! Thanks a lot @Pavel_Abaev :smiley:

Yup, because this wasn’t an issue before, so definitely something weird going on here…

I actually came across this today and it looks like the Airtable app in Make has some issues, indeed. It automatically turns the input date into a date and time, causing an error in Airtable if the field is a simple date field.

Basically 2022-03-01 input becomes 2022-03-01T07:00:00.000Z in the API call body. The Airtable app in Integromat is actually able to see if the Airtable field is Date or Date & Time and adjust the API call accordingly.

So it works in Make if the Airtable field is a date and time field or if the Smartlink is ON.

2 Likes

This is what I got back from support just now:

I have been just informed by the dev team that the issue with the Date values not being sent has been fixed. Please give it a try and don’t hesitate to let me know in case it still wouldn’t work as expected by any chance.

I would like to apologize in the name of the whole Make team for the caused inconvenience.

Let me know should you have any further questions.

So it should work now! :smiley: