Android SMS not sending

i want to send an SMS text message with the Android module
i have connected my device, Xiaomi device, and enabled the SMS functions on the app, but when i send the SMS via scenario i don’t receive the text message

im getting this error:
Unknow error while sending message to the server

is there any extra steps to do in the app to make it work?

Make sure you have the SMS permission granted.

If this doesn’t work, try using a Google Pixel 6 or later phone, as it works for me.


i have a mi 9 lite, kinda new phone, i tried it also with a newer phone, all permissions granted as well on both phones, nothing worked!

Try it with a stock android phone, a Google Pixel 6, 7, or 8.

Xiaomi devices are known for its incompatibility with some android features, because they roll their own UI & permissions management is slightly different.


the issue is caused by Android, even support confirmed it in my ticket with them
i think the make android app should be updated to prevent blocking in the background

1 Like

Firstly, there are two versions of the Make Android app.

The one you are installing from the Google Play store has restrictions, and might not be able to send SMS due to Google restrictions.

To install the full, no-restrictions version, see the Help Center for the official link:



Then, ensure that you have granted the following three android permissions for the app.

Allow SMS

Unrestricted data usage

Unrestricted background usage


i know, those settings you mentioned were applied and the same issue appeared on 3 different phones

@Mohammed_Breky did you manage to get the Xiaomi phone work?

I tested with two phones, for me the Google Pixel 6 works and the Xiaomi Mi 9 Lite triggers upon received messages, but cannot sent message.

I’m using Make’s

  1. unrestricted app with
  2. SMS perrmission and
  3. unrestricted battery / background usage
  4. but there are no data usage settings.

That’s what I said. The solution is don’t use Xiaomi.

I have both Google and Xiaomi phones, and similarly the Xiaomi one doesn’t work.


Update: I swapped the SIM slot from 1 to 0, deinstalled and reinstalled the unrestricted Make app, now both sending and receiving SMS works. Let’s see if that runs stable or stops again. :wink:


Hey there @Zbulo :wave:

amazing to hear that you successfully got rid of your problem! Thanks a lot for keeping us updated. :pray:

FYI: I marked your comment as a solution to keep our community organized and neat. This way other Makers can benefit from your idea as well.

1 Like