Anyone else encountering `'parseError' finished with error!`

image

I’ve now seen 2 large instances where multiple scenarios - all of which are triggered by an Airtable ‘Watch for New Records’ module will throw this same error over a 15-30 minute period.

I’ve flagged to Make support, but received this in an auto-reply the next day:

Curious if others are facing the same issue (and if that was what’s fueling the massive number of requests), but haven’t seen any other threads citing it :person_shrugging:

Hi @Pat_Martinson,

Could you send some screenshots of the setup of the module that gives you this error? Also please add a screenshot of the input data for the execution that fails.

Thanks

Loic

I can certainly try! However It happens across so many different scenarios, it’s hard to pick the ‘right’ ones to screenshot. Some are very simple:


image
image

While some are more complex:

Any other specific details you’d like to see?

Thanks, did you change the structure of the table your watch modules are querying?

If adding fields ‘counts’ as changing the structure, then yes we have for some, but not for others. It’s happening across multiple tables (but I believe they’re all in the same base). Again, it’s happening on so many different automations that we haven’t been able to systematically track it :face_with_spiral_eyes:

Ok I suspect there are two things going on here:

  1. When Make calls Airtable, Airtable errors for some reason to be determined.
  2. Make then tries to process/parse Airtable error message and fail. I think this is what the “Function 'parseError …” message is about.

So basically an error on top of an error.

My suggestion #1:

Try to reset the starting point for your watch module. Right click on the module, click on “choose where to start”, select your new starting point, click ok and then try to run your scenario.

If this does not work try to do this:

  1. Download Integromat/Make dev tool: Integromat DevTool - Chrome Web Store
  2. Open the dev tool in your browser and run your watch module
  3. See exactly what Airtable respond to Make by checking the response header and body

This will not solve the problem but you will be able to see what Airtable is saying about the issue. This may shed some light.

1 Like

OK, I will give this a shot, and thanks for the detailed answer!

One thing worth noting (and I may not have mentioned before): this is happening sporadically, and it will be a small-to-medium “burst” of several scenarios throwing the error at the same time.

Then they all run properly again. So I think it will be harder to catch the error, but I’ll give it a shot.
(and as a final clarification: we’re seeing 502 or 503 timeout errors from our AT modules occasionally, but the error code is distinct from these)

How many times did this happen? Could it be related to some Airtable or Make outages? It sounds like it

We’ve had 3 instances where this happens across several different scenarios:

  • Nov 28th: 8 unique scenarios, 1 on each
  • Dec 1st: 8 unique (they are not the same as Nov 28th), 1 on each, 7 instances from 1 scenario
  • Dec 2nd: 13 unique scenarios (some same as previou days), multiple instances from 5 scenarios

So at this point, we haven’t seen the error come up since Dec 2nd, and more importantly it seems like this is a corner-case issue, that hasn’t been seen widely by other users.
I think those are both good things? :man_shrugging:

Wanted to circle back with an update from Make Support:

As I have further checked the logs with this same error, it seems that the issue is within the Airtable server as it throws error 503. I would suggest reaching out to their support team if the issue still persists

We have not seen the issue again, but if it’s tied to 503 errors, I think it means we need to cut down our Watch Records triggers.
Thanks again to @loic.wiseflow for your insights, and hope this is helpful to others if you encounter the same issue.

2 Likes

Heya @Pat_Martinson :wave:

I just wanna jump in real quick to say that we really appreciate you stepping back into the community and sharing the message you got from the Support team :pray:

This can, indeed, be super helpful to someone one day. Thank you for thinking about the other Makers :blush:

1 Like