Calendly scenario run — „waiting for data”… and waiting… and waiting


I’ve been trying to set up the simplest automation scenario — Calendly+Airtable.

Something is not adding up here with Calendly -
although the webhook seems to be properly configured (also Airtable scenario set up seems to be working fine) when I run the test scenario for Calendly, it gives no results, apart from „The request was accepted. Waiting for data.”

I tried to resetup the scenario dozens of times and it worked in one case — unfortunately I was unable to reproduce it.


Using Instant Triggers like Watch Events, Whenever you run the scenario it expects that there is any event in Calendly only after which the Make Module with receive the data and then proceed forward with Other subsequent modules.

So, If you are like watching events for new event in calendly, whenever you are test running the scenario, you will have to create a new event in Calendly in order for the Watch Events module to get any data.


You can also right click the Calendly module and select Choose where to start if you want to test with an event in the past rather than create a new one just to test the scenario.

Oops! MSquare pointed out that this is an instant trigger, so you can’t select where to start, just need to wait for something to happen in Calendly to trigger the scenario.


Thank you very much for your suggestion!
So what’s the right schedule setting I should pick?
(I expect the scenario working for any new event starting from today.)

Hi @Artur_Mesjasz

The “Watch event” is an instant trigger, so it will provide the output as soon as changes occur in Calendly. Please ensure that you use the “immediately” option to receive the trigger instantly.

If you require additional assistance, please don’t hesitate to reach out to us.
MSquare Support
Visit us here
Youtube Channel


Funny, I’ve suddently started having my Watch Events module not get any data when I schedule a test event.
After several minutes, still:
Anyone else experienced this? Assuming it’s just a temporary API issue. I just reauthorized & re-verified my connection so I think it’s on Calendly’s end.

I found a solution that worked for me was creating a new webhook.