Cannot connect to Webflow account

I’m unable to connect Make to Webflow… Been trying for a couple days now and it only ever gives me an error like this:

{"message":"The request failed due to failure of a previous request.","code":"SC424","suberrors":[{"message":"Status Code Error: 400","name":"RuntimeError"}],"debug":[["request","POST","https://api.webflow.com/oauth/access_token",{"body":{"code":"***","client_id":"REDACTED,"grant_type":"authorization_code","redirect_uri":"https://www.integromat.com/oauth/cb/webflow","client_secret":"***"},"headers":{"user-agent":"Make/production","content-type":"application/x-www-form-urlencoded"},"timeout":40000,"type":"urlencoded"}],["response",400,{"body":{"error":"invalid_grant"},"headers":{"content-type":"application/json; charset=utf-8","date":"Wed, 28 Sep 2022 20:09:29 GMT","etag":"W/\"19-6ab892\"","x-response-time":"27.138ms","x-wf-rid":"3b84b2a0-c9eb-454e-ba8f-bd008cc148ab","content-length":"25","connection":"Close"}}]]}

This appears to happen on Make’s side. On the Webflow side, I see a Make.com integration added in my Integrations screen, but Make never receives the callback or whatever the secondary step is to add it to my account and let me use it in a scenario. Stuck at a standstill…

Have tried selecting my entire workspace, just the project I want to connect to, both of those things, all of the things… Nothing works.

What am I missing? How can I get this going so I can get to work?

Thanks

Same on my side.
I tried multiple times without success :unamused:

Yeah, still not working. Looks like I’ll have to find another option.

The error makes it look like it could be an oAuth issue, meaning your authentication with Webflow from Make.

Make has been having some service issues lately so may you’re effected by it.

If you paste a screenshot of your Make Scenario I can try and help troubleshoot it for you.

There’s not a whole lot going on in the Scenario. Make an HTTP request, send it to Webflow. Can’t really do much without the connection working, so this is all I have. The account is brand new, I have no other connections or anything else set up.

I’m confused.

Can you please open up your HTTP module and screenshot the settings?

I’d like to see where you are making an HTTP request, to?

Well, now I’m confused too. The problem has nothing to do with my HTTP request, I’m not even doing anything with that data for that to be a factor. For what it’s worth, I’m making a basic HTTP request to an API endpoint to fetch a few records. That works just fine and would not play a part in Make not being able to connect to a Webflow account.

I need a connection to Webflow in the first place so that I can do anything with that data at all, which is what is failing. This is a problem on Make’s side, so far as I can see.

The screen after this opens a Request for Permission screen on Webflow, where I select my workspaces and/or projects I want to provide access to Make with.

Regardless of what I select here, I’m met with the error in my original post (as is the second poster). Screenshot cropped to redact the client ID, but the error is the same as above.

Okay, good.

I’ve seen some people confused and attempt to use an HTTP module to call the next module (a Webflow module), which of course makes no sense.

Your last post was an effective way to communicate your problem for troubleshooting, well done :+1:

This is what I was also thinking may be a problem, looks like that is confirmed. Not yet convinced it’s on Make’s side, though.

Give this a try…

Head over to the Webflow API Docs: Webflow CMS API Reference

Grab your Webflow API Token (Webflow Project Settings → Integrations → Generate API Token) and slam it into curl request.

Also make sure to add your Webflow CMS Collection ID into the url of that API call.

If you do all that and correctly match field names you can see if this is a “Webflow problem” or not.

Use Postman / Insomnia if you’re familiar with those tools, too.

Narrow down if this is on Webflow’s side, or Make’s side.

Depending upon that answer, you can get the problem resolved.

1 Like

@here

Heya everyone, thanks so much for raising this here!

Our dev team is now aware of this and they should start fixing the issue soon. I’ll make sure to keep an eye on this and let you know once it’s resolved.

Thanks for your patience and understanding :pray:

1 Like

:raised_hands: that’s filled with awesome

1 Like

also… in the mean-time if it’s urgent you could always trigger a Webflow Webhook yourself. Have that sent to a Make Webhook. That’ll avoid the Webflow module and these issues. This has been working without issue for me.

same error here for a while. Deleted my make account and the connections on webflow, still no luck

Having the same issue here ^^

Please help support team!

Me, too! Are there any updates around this topic? I am new on “Make”. Not Understandable if that happens when I have sign up 2 hours ago and the topic is one week old?!?!?!

Hey folks, welcome to the community! Once again - so sorry for the trouble this is causing you.

@Dom_NICK Unfortunately, I have no updates on this at the moment. Our developers are aware of this and are working on fixing the issue. Once that’s done, I’ll make sure to announce it in this thread.

@joehanauer This is a user community which means that we don’t have access to your account/scenarios/logs. If you’re looking for the assistance of our support team, please log a ticket in our system.

@lassoomon So sorry for the inconvenience. I’m sure the fix will be deployed soon and all will go back to working normally. I’ll keep you posted here.

Thanks for your patience and for your understanding, everyone.
Sorry this is taking a while; we’ve had a busy couple of days with the DDoS attack. Thank you for bearing with us :pray:

1 Like

Thank you for the update @Michaela, please keep them coming!

1 Like

Had to reopen my ticket after it being auto-closed. Still waiting for a resolution.

Wanted to check if there’s any sort of an ETA on this fix?

Hey everyone!

I’m really sorry that I cannot give you a specific ETA on this. Based on our internal info, the issue should be fixed really soon. I’ll make sure to let you know in this thread as soon as I learn about this being resolved.

I understand that this is frustrating and I’m very sorry for the headache this is causing you. Once again, thank you for your patience :pray:

@here Hello everyone :wave:

:white_check_mark: The issue has been fixed and all should hopefully be back to normal now.

I know this has been a pain for you all and I thank you for your understanding and for bearing with us over these couple of days :pray:

1 Like