Customizing Slack Messages Posted to a Private Slack Channel

When errors occur, I am looking to post custom error messages to a private Slack channel.

I am not seeing consistent behavior for the icon emoji and bot name coming through in Slack. I’ve been trying different combos.

For the emoji, I’ve tried pasting in :rotating_light:, and rotating_light (with colons)

Any advice?

Thank you! :pray:

Desktop-screenshot - 2022-05-01T161818.135
Desktop-screenshot - 2022-05-01T161638.351
Desktop-screenshot - 2022-05-01T161429.833
Desktop-screenshot - 2022-05-01T161339.970
Annotate-Image

1 Like

Hi Colleen,

I have never had issues with icons using the colons in the emoji field. Regarding the bot name, did you try adding a value to the User Name field? That should override the default setting.

Thanks @loic.wiseflow.

Yes, I have had a User Name in some versions but not others.

Thanks for taking the time to look and respond.

Did you try to compare the API request body from two requests that should have been identical but displayed different bot name and/or icon?

@loic.wiseflow - No. I hadn’t. (Not sure how to do what you’ve suggested, but will research.)

Observation from recent tests: I am noticing that if I don’t use the Blocks option, my icon and bot name appears fine in Slack.

I also duplicated some recipes and noticed that the “Blocks” option doesn’t exist and the supporting explanation for text differs.

Using Blocks is new to me. I’ve done test with samples from Slack and some of my own.

@colleen I think your scenarios are using two different versions of Slack. The one without the block field is an older one (that you can only access by cloning an older scenario)

That makes sense @loic.wiseflow. Thank you for the continued support.

The example on the left is a scenario I duplicated from Make as part of troubleshooting. It did look older.

The example on the right is from a scenario I created after upgrading to Make and is made from scratch.

From my current tests, using Blocks prevents the Username and icon from appearing properly in Slack. As soon as I stop using the Blocks option and only enter text, the bot name and icon appear fine in Slack.

I’ll do some more tests.

I just did a quick test with blocks and the icon and username are showing correctly.

To compare the data sent to Slack in both cases run a test a check the data input by clicking on the download icon and then “Download input bundles”

1 Like

Thank you @loic.wiseflow.

I had not used that feature before in Make. Glad to now know about it.

I’m also seeing the icon appearing fine via the “Download input bundles” option. Perplexed, but know more than I did when I started.

Thanks again!

@loic.wiseflow - Thank you again for your help.

My icons and app name are coming through fine after all.

I suspect that I was sending too many tests in a short period of time and Slack was not displaying the icon and app name. Now that I have spaced my tests out, everything is working fine.

Have a great week.

Hi @colleen,

Yes this the default behavior in Slack. If you send messages close together they get displayed “bundled”

image

Thank you for keeping me in the loop :slight_smile:

1 Like