Error upon error when trying to tweet images from airtable


So I’ve been posting tweets automatically without any problem, but when I try to add an image I get error upon error. Here are some of them:

The operation failed with an error. [400] media type unrecognized.

The operation failed with an error. Cannot read properties of undefined (reading ‘emit’)

Validation failed for 1 parameter(s).

  • Array of objects expected in parameter ‘attachments’.

This is the setup I use to tweet, which works perfectly when posting text only.

I’ve also tried using an aggregator, html/css to image, deleting the ChatGPT module and everything else I could think of, but nothing seems to work.

I’m new to all this automation and code, so I think I’m just missing something and I’d like to think someone here probably knows there’s a simple answer to this, hence I’m asking here.

Thanks in advance!

Hi @Davey_b

It seems you have not handled image mapping properly in the module. Also, select proper/map proper image type.

If you need assistance, don’t hesitate to contact me.

Mohamed Jahar

1 Like

Thanks for your reply. What should I change here?


I’ve also tried to not map it and do it this way, but that doesn’t work either:

Hi @Davey_b

Please download image data using the HTTP module “Get a File”. Then map its output in Data field of attachment section.