Google Authentication issue: Status Code Error 400

Hi guys,
I have a scenario which i search for a random file on google drive on a specific folder every 7h and do some other actions with this file. it works fine for like 1 or 2 days but after it shows me an error:Status Code Error: 400 and my google drive connection disconnect.

Is anyone here can help with that. Thanks

1 Like

I have the same problem. Every 2 days I recieve this email:

Failed to verify connection ‘My Google Restricted connection’. Status Code Error: 400

Then I have to verify the account in Make every 2 days… I’ve tried to verify the account through a make scenario but it can’t be done…

Does anybody know how to, at leas, increase the time that We have to verify the account?

Thank you very much

1 Like

I’m having the same problem, anyone found a solution?

Exactly same over here!

Every 2/3 days my scenario breaks because of that motivate. It is quite frustrating. Any fix we could apply to solve it?

Hey @Itay @Saza @D_Leon @My_Cute_Cub ,

If you are using a paid gSuit / google workspace account you can connect to it easily by using oAuth2. However, if you are using a gmail account there are some more actions you have to take before it works properly.
Please read this document thoroughly: https://www.make.com/en/help/connections/connecting-google-services-using-a-custom-oauth-client

Hope this helps!
~Bjorn

@Drivn.agency
I did all of that actions but it still disconnects every 2 days. I don’t have a paid G Suit account.

1 Like

So you are now using a client ID and secret instead of oAuth2? @Mikolaj

hello @Bjorn.drivn , Im using client ID and secret as is shown in the tutorial you sent and doesn’t work

image

I see that the issue is older than my account,
please any fixes for this issue?
I did exactly what the make tutorial sais and followed all the instructions but it keeps losing connection every 2 to 3 days, it’s so random that it’s impossible to track,
please help

1 Like

Let me look into this again @Houssam and come back to you.
Can you give more details, like:

  • What kind of app would you like to use (drive, gmail etc.) ?
  • Which scopes did you provide ?
  • When did you start seeing this issue?

Thank you!

1 Like

Hey @Houssam , @D_Leon , @Mikolaj, @Itay, @Saza , @My_Cute_Cub here is what I figured out while testing a Google Connection without a paid gWorkspace account.

! Please keep in mind that I would always recommend using a paid gWorkspace account if you are using the Google API intensively inside a company environment. There will always be more restrictions/limitations on (free) gmail accounts.

I have ran 2 seperated projects calling a Google Drive API for multiple days to test out my hypothesis. After 7 days my hypothesis was confirmed and might help you. These are the following accounts/projects I tested:

  1. A gmail account with a project which was in “Testing” status.
  2. A gmail account with a project which was in “Production” status.

I’ve ran both tests 1x per day, creating a google drive folder and deleting it again:

After 7 days the “testing” project got verification issues with gDrive. This would confirm my hypothesis that “testing” projects will have their refresh token expired after 7 days.

Here are the differences and how you can fix this yourself (please read the text below the images for the full picture & “solution”):


Testing project


Production project


Within your Google Cloud console publish the project

The google cloud console can be found here. Then you have to go to “API & Services” and open the “oAuth consent screen”.


After publishing it will state it requires verification. This however is not required and it seems to work without verification for a long period.

What was not tested but might be affecting this case:

  • We did not test out the possibility of loosing a connection when you are not running the google API recurrently. Our test had the API calls being made daily.
  • We did not test this out for a long period of time. This was only just longer than a week. It might be that the Google API will still loose connection after a certain period.

Please test this out and let us know how it goes. If this solved your issue feel free to “heart” this answer so we know you got it solved :smiley:

1 Like