Google calender api error

Im getting this error from google calender. 403] Request had insufficient authentication scopes.

I already have all google api scopes for google calender enabled in google cloud console. So, I really have no idea why I’m getting this error.

It had worked in a different account before.

Please provide a screenshot of the scopes you have set.

Please go to your connections page and reauthorize the connection. This will update your OAuth connection token with the new scopes you have added to your GCP project.



hey ive got the same issue. Any chance someone can share how to set up the advanced auth inside of

Ive added the scopes but no idea where/how to set this up in make

It depends on which endpoint you are calling.

Please refer to Use Gmail Settings API with HTTP Make an OAuth 2.0 Request to get Signatures - #4 by samliew for instructions on how to add scopes to your GCP OAuth application consent screen.


hi - the gmail settings dont apply here. I am asking for Calendar - I need to know what scopes needs to schedule events in the Google Calendar API. Ive added all the ones that should work but still getting a 403 error

I have set up all the Oauth config as it connects but its still saying insufficent scopes

Tried reauthorize and deleting and adding the connection again - same issues

Can someone share details of the OAuth set up for Google Calendar to create events thanks

The instructions are the same, you’ll just need to select all the available scopes, or search for “calendar” in the scopes table and select them.

For more information, see


hi - they are not the same at all my friend!

Here are the published Make instructions for Connecting a Google Calendar to make*1qawb2e*_ga*MTA5ODg2ODE3Ni4xNzEyODMxNjI2*_ga_MY0CJTCDSF*MTcxMzAyMDAzNC42LjEuMTcxMzAyMzI0Ni42MC4wLjA.#google-calendar

Now it doesnt matter what I do - basic create a connection or setup Google Cloud Console for Calendar following these exact instructions the Calendar will NOT connect as authorized in make

If I go to connections and view permissions the calendar is not there

I have now tried this endless times from scratch.

I only have these permissions

  • View user’s email address

  • openid

So any way can you follow these exact instructions and let me know what is missing/changed?

I am not able to connect my google calendar as an API module in make

Do you need a google workspace account?
Does the console app have to be published as external (this is the only option for non workspace accounts)