Help with my scenario

When asking your question, please include:

:footprints: The steps you have taken
:camera_flash: Relevant screenshots
:link: Any links you have
[ Code { "and": "JSON", "in" : "code block"} ]
:x: Exclude Personal Information.

Hello all,

I work for a non-profit and therefore use the free plan (I only have 2 scenarios). One of my scenarios is set to watch a google sheet for form responses (volunteer applications), and then transfer that data to a board, where I manage all of my volunteers. I recently had to update the Volunteer Application, subsequently updating the Google Sheet, and therefore my scenario in Since making this change, my scenario no longer works.

It is set to watch the correct google sheet and create an item in the correct board. There are no error messages, so the scenario appears to be working, but it isn’t transferring the data from new rows of applicants? I have tried contacting their support, but they refuse to help, because I am on a free pan? Is anyone here able to point me in the right direction?

Image 1 shows my scenario.
Image 2 shows the settings for the ‘Watch Google Sheets’
Image 3 shows the settings for create an item in

Many thanks,


Hi @GBRLegacy,

Right-click the Watch New Rows Module, And, then enter the last row ID of the newly created sheet or Choose Manually to select the last row. It will reset the rowID and will then pickup any new rows being entered in GSheet from now on.

1 Like

Thank you. That certainly did something different, but now I get this error message?

“The operation failed with an error. [200] [{“message”:“Parse error on "columnId" (STRING) at [1, 126]”,“locations”:[{“line”:1,“column”:126}]}]”

Hi @GBRLegacy - if entering the ID didn’t work, just try manually selecting the row you want the scenario to start picking up data from again, as @Runcorn said.

Select “Choose manually” and it will show you the records from the Google Sheet. You can then select the first of the records that the scenario has missed. Then just keep running the scenario until there are no more records to process.

1 Like

Thank you. Yeah, I tried that, but still getting the same error message?

“The operation failed with an error. [200] [{“message”:“Parse error on “columnId” (STRING) at [1, 126]”,“locations”:[{“line”:1,“column”:126}]}]”

It’s hard to know what might be going on without seeing the google sheet or the whole of the scenario. Is the google sheets module throwing the error?

Is there anything in the cell in the first line of data at Column 126?

1 Like

Unfortunately the sheet is confidential, but the error is coming from the module.

There are only 77 columns, so no column 126.

Can you post an anonymised version of the output from the first module?

@GBRLegacy, This could be anything. Can you cross-validate all the fields and see if there is any discrepancy between Gsheet data and what is expected on

Just crosscheck the date format expected in Monday against what you have in Gsheet, Check whether the status labels are missing. Just review it thoroughly and see if you can figure out this issue,