HTTP make a request doesn't work

Creating a simple HTTP request Doesn’t work
It’s just a simple request from a url but instead to finalized it keep going.

i checked the status but looks working.

Can you share the module settings here for HTTP request?


Here are a few steps you can take to troubleshoot the problem:
Verify request configuration: Double-check that you have configured the HTTP module correctly. Ensure that you have provided the correct URL, selected the appropriate request method (e.g., GET, POST), and included any necessary headers or parameters.
Test with a different URL: Try using a different URL in the HTTP module to see if the issue is specific to the URL you’re currently using. This can help determine if the problem lies with the URL itself or with the configuration of the HTTP module.
Check response status: While you mentioned that you have checked the status and it appears to be working, it’s still worth verifying the response status code. A successful response typically has a status code in the 2xx range (e.g., 200 for OK). If the status code is outside this range, it can indicate an error or issue with the request.
Review error messages and logs: Inspect any error messages or logs that are generated during or after the execution of the HTTP module. Look for any specific error details that can help pinpoint the problem. make,com usually provides error messages or logs that can assist in troubleshooting.
Test with a different tool: Use a tool like cURL or Postman to make the same HTTP request outside ofmake,com. This can help determine if the issue is specific to the make,com environment or if it persists across different tools. If the request works outside of make,com, it may be necessary to review your module configuration or seek assistance from make,com support.
For Solve quickly Expert Suggestion


Thanks for help but I think the problem is on MAKE side because when i run also it can’t be stopped. like it’s bugged.

Sometimes works sometime not.

Hi @alfredo_girella,

I don’t think the issue is on the Make end, as the API request success or failure entirely depends on the service that you are using.

Going through the document, the error documentation for this is not good and it might cause error depending on how the API is functioning.

Check the details here,


@Runcorn I’m not sure that’s the same service …

@alfredo_girella I’ve just had the exact same HTTP call running every minute for 15 minutes - no problem at all. As @Runcorn suggested, it’s likely to have been a problem at their end, maybe a temporary one.

I can assure you that the HTTP Make a request module works just great - it’s used in a vast number of customer scenarios!


i’m using also this website to create fake API (Fake API - Dummy User and Todo API - Create Your Own) but still doesn’t work… depends… sometime works sometime not. do you have an API to test please? I’m using a free version. could be that the problem? i’m also using some random API GitHub - davemachado/public-api: Public API for the public-apis Github project to test but still doesn’t work.

Other platform show the correct result. Also when Make don’t load.

free plan but i’m using also other API provider

My bad, will modify the link

@alfredo_girella the only relevant limitations on the Free plan are:

  • Max 2 active scenarios
  • 5 min max scenario execution time
  • Scheduled scenario interval 15 mins or more

If none of those are likely to be affecting your scenario, could you send a Loom video of the problem you’re getting?


A post was split to a new topic: HTTP Request: Status Code 401 and “Data: Unathorized”