HubSpot Watch Companies Modul - Request rate limit

Hello,

in my scenario I only have one module - “HubSpot CRM Watch Companies”.
When I click the option “Run this module only”, I get the following error message:

The operation was completed with a warning. [429] You have reached your request rate limit of 100 requests every 10 seconds. Please consider using a “Sleep” module together with the “Resume” error handler to retry after 10 seconds. HubSpot Correlation ID: 198a8379-a85c-488d-b7ce-ef465382329c

Module settings:

Can you help me with this problem?
Thanks

Hi there,

From the looks of it, it appears that you have reached Hubspot’s API rate limit. Should be fixed in a few seconds-minutes. Do you also have other Scenarios that use Hubspot? Try to add an IGNORE error handler so that it won’t deactivate the Scenario once it errors out.