I cannot attach a file in a trello card ( Trello Add an Attachment module )

Hello to everybody.

Even if you think this post is rubbish, please let me know if the screenshots are rendered since they do not appear rendered when you compose the post

i want to Attach a ‘physical’ file in a trello card.

i can attach a link, which is an airtable temporary link, so it is of no use.

i cannot find the way to attach the real file ( .pdf )

I have tried to map all of the values listed under the airtable field containing the file.
Capture d’écran 2023-09-02 à 13.36.00

it keeps attaching 1 to 17 bytes size files which are not at all PDFs.

is there any reason why the physical file would not be in the get a record module ?

i do not have any error messages.

Thanks in advance, :+1:

One more precision :face_with_raised_eyebrow:

The file exists and is manageable since in another workflow, it is attached to an email by an airtable automation. It seems that it is on the Make side that i cannot handle the file…
In this screenshot, ‘the_pdf’ is an attachment field

Welcome to the Make community!

Could you please share screenshots of the module fields and/or filters in question? It would really help other community members to see what you’re looking at.

You can also export the blueprint file to allow others to replicate the issue. At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.


Uploading it here will look like this:

blueprint.json (123.4 KB)


Sure thing !

Get a record in Airtable module

Add an Attachment in trello module

the last airtable module is of no interest, it just updates a field in the record gotten in the 2nd module

Finally i lied once more in my community.make.com profile, since i run Make on the free plan, but intended to go core in a very brief time. In case it is a hint for our matter

Thanks for your time anyway.

Here’s the blueprint :grin:
blueprint.json (36.2 KB)

BTW Does it mean you can import those blueprints on other accounts in order to build for clients ?

Salut @gilles_prevotal,

Your Trello “add an attachment module” is expecting binary data and you have mapped the file name.

To achieve the desired result you need to “get” the data first. Your Airtable module returns the URL of the file, not the file itself. So you need to add an HTTP “Get File” module first.

Then you map the returned data into your data field in Trello.


I was feeling i was missing smtgh, but what ?

Thank you so much, merci bcp Loïc.

Works like a charm :+1:

1 Like