Instagram /linkedin not posting from airtable

Automation is supposed to make life easier but I constantly end up spending my entire day troubleshoot these things rather than them working for me.

I am trying to post a reel post to instagram and linkedin but I am getting hit with this error. Everything is mapped correctly to my knowledge. Any help is appreciated.

Hi Ryan,

you need to get the file first using an HTTP Get a File module. Then you map the output of that module in the File parameter in LinkedIn.


Makes sense is there a youtube video that shows how to do this?

Here is one of my flows:

The image in my case is a ClickUp task attachment and I pass the URL to the HTTP Get a File module → then pass the output of that module to LinkedIn.


Thank Stoyan, can you show me the set up for the HTTP. This is how I’m trying to set mine up but it doesn’t work.

@Stoyan_Vatov Would you be able to help me out please

Looks like there is no url coming in. Can you check it manually and see if it works?


This is where I get lost. Where would I be able to check it manually?

If you’re available or offer services where we can share screens I’m happy to do that. I know this takes about 10 min once I’m on a call with someone.

Check the incoming bundle to see if a url is coming. If it is → you can copy it and paste it in your browser to see if it will be resolved.


You mean this bundle? Sry I’m not all familiar with the correct terms. Screenshots always work better as I’m new here.

I see a URL availabile in Airtable and a url the pulls through for the http.

I copy and pasted the URL and this is the error I am getting

Looks like the URL in Airtable points to content that is no longer available, or a non-public URL that needs to have the sharing permissions set to public.

Try clicking on the support center link shown in your first screenshot for more information.


appreciate everyone’s help here. i solved it. Hired someone on FIVER>

Here’s the tea:

  1. Need to be on a pro plan.
  2. Need to add a filter . Basic operator exists and then add > media URL in
  3. Click save and then run it.

Now I am encountering a new problem.

I run it but it only sends the video to my linkedin and not all of the other platforms.

Screenshot 2024-04-01 at 10.50.48 PM


Hey there @Ryan_O_shaughnessy :wave:

Great to hear that you’ve solved your problem with @Stoyan_Vatov’s and @samliew’s help!

Also thanks a lot for updating us on the issue!

1 Like