Is there a way to stop a scenario deactivating for an error on one execution?

I understand that on a scenario I can add error handling with every app, but is there any way to keep a scenario running (processing new executions) without doing that?

As in ideally there is some global ‘don’t deactivate this scenario when it errors, keep processing new executions and email me to let me know of the one execution that failed’. Does such a setting exist?

Hi @Joseph,

You can go to Scenario Settings > Advanced Settings > Number of consecutive errors, you can increase the value to higher value.

Thanks, that’s what I thought. But I had that set to 10 and it still turned off on the first error. Is there any other setting I have to change in conjunction?

Can you share me your current scenario settings?

1 Like

Can you also show the output of your run where it crashes the first time? Then we can see the error @Joseph

1 Like

Not sure what you mean by “output”, can you clarify? Just a screenshot of the error?

I checked another one of my scenarios, which always turns off after the first error and it’s set to 3 consecutive errors. So it seems to have the same problem i.e. not scenario specific, which either means another setting that needs to change (?) from those I am using on all scenarios or perhaps a wider issue?

Any update on this? I’m having same issue. No matter what I set, it always goes off after one error.

I worked around it by adding error management of ‘ignore’ for each module, which is not ideal as I don’t know when it has failed other than a lack of output for my particular use case.

Any thoughts given the output @Bjorn.drivn?

Hey @Joseph ( and @Jaroslav_Dlask) ,

So with output I mean the output of the certain module that is generating the error. You can identify this by the round cloud thingy above it
Screenshot 2023-07-17 at 11.38.33

Once you click on this, it gives back the output of the run. However…

The screenshot you gave above also gives back some valuable info . As you can see in there it states “Missing value of required parameter ‘url’” within the HTTP GET file module. This basically means that there was no URL filled in, which in this case is pretty critical since you are trying to download something from an URL.
I do not see your full scenario in a screenshot so I can not tell you where it’s going wrong, but instead of adding ignore error handlers I would recommend you to backtrack the issue itself. Most likely you have filled in a variable within the HTTP module (for the url), but this variable is empty so it fails.

Hope this helps you.

@Bjorn.drivn, thanks for your reply. I understand why the scenario failed and what is going wrong.

This automation is linked to a form where I can’t validate data before the scenario kicks off, so that means there will sometimes be an error. A customer enters a piece of data that is invalid and so there is no URL to retrieve… that’s fine.

But what I would like to do is stop the scenario from turning off when it experiences an error.

It seems the “Number of consecutive errors” option does not work as advertised, because it is set to 10 on the scenario, but fails on the first error, every time.

1 Like

@Joseph got it, think I misunderstood you there then :wink:
So what you can do in this case, is use the error handlers as you’ve done already. If you don’t need the URL etc. you can use the “ignore” as you’ve done.

With error handlers you can also use routers, so if you want to notify yourself of an issue, use something like a Slack or Gmail module to also send a notification to yourself.
You can see this happening (no notification but multiple error routes) below:

Hope this helps you!

3 Likes

I’m also facing the same issue.


A lot of times, the Hubspot or Google Sheets API doesn’t respond and the scenario shuts down.

This is quite inconvenient. It should just error out that particular execution (generate a notification/alert) and move ahead. I checked in advanced setting, the consecutive failure number is set 3, still it goes down on 1 error.

Pls help.

1 Like

Ok…I figured it out - You need to connect an error handler to a router. Connect one part of the router to the Ignore and the other to your other modules you want to do stuff with. If I test a run and trigger it, then the output shows Success, but it was an error.

2 Likes