Issues with Airtable fields that contain spaces

Hey All,

I’ve had this bugbear between Make and Airtable for some time but can’t figure out the cause.

Basically, I find Make struggles to find Airtable fields with spaces in, until it magically figures it out, then it’s fine going forward.

For example, if I use the search Airtable module with a formula like {Pickup Date Days Since} >= 7 I’ll get the error [422] The formula for filtering records is invalid: Unknown field names: pickup date days since, even though this exact formula works in Airtable i.e. the field exists.

I’ve had this issue a number of times, and it’s always when there are spaces in the field. So If i rename the field to ‘pickupdatedayssince’, it will find it just fine.

Has anyone come across this or can identify something I’m doing wrong? As I say above, after messing around, it sometimes picks it up…


Hi @SdogEeinnarg

The Airtable search module formula should exactly match the column name with the Airtable field name. Please try copying the field directly from Airtable and pasting it into the search module.

For more information about Airtable formulas, please refer to the link below.


Yep, I’ve tried copying it exactly. Same result. The way I generally fix it is by removing the spaces from the field, then running the scenario (while removing the spaces in the search formula too). The search then works. I then add the spaces back in (in the field and search formula) and it continues to work. It doesn’t really make any sense…
Like I said before, I’ve run into this issue every time prior, just this time I decided to post here about it. The first time or so it was infuriating because it made no sense why the search formula wasn’t working, so at least this might help someone else troubleshoot the same issue.

Hi @SdogEeinnarg,

Could you add a screenshot of your formula (maybe there is a typo, it is quite common)?




It’s that predictable I can replicate it with an example.

Hi @SdogEeinnarg

Please try the formula as below.
{One Two} = ‘1’

I have tried in our airtable for a formula column and it’s working.



Your example doesn’t have the nuance of a field with a space in it - this is the primary cause of the issue, as far as I’ve tested, which is why I used the field name ‘One Two’ in my example instead of just ‘Formula’. Either way, I tried {One Two} = ‘1’ and received the same result.

I’ve tried all sorts:
{‘One Two’} = 1
{“One Two”} = 1
{[One Two]} = 1
{OneTwo} = 1
{One_Two} = 1

Nothing works. The only way I make it work, is to rename the Airtable field to ‘OneTwo’. Adjust the formula in Make to {OneTwo} = 1. Run it, get a working result. Then, rename the Airtable field back to ‘One Two’ and re-adjust the make search formula to {One Two} = 1 - then it works. Almost as if it’s now found that Airtable field and can work with it. This is how I’ve got around the problem so far, but as you can imagine, it’s just annoying.

Basically, the search filter with formula should also work for a column name with a space in it.
I’ve tried with the same naming and I get normal results.
I used same kind of formula (TRUE/FALSE results) and column name ‘One Two’:

Used the column name in the search formula in Make:

and I get normal results:

Not sure if this is a Make issue, or more an Airtable buggie. Maybe you can check the Airtable community for similar issues, or submit a support ticket?


Thanks for running a likewise test - it’s interesting to see it works fine for you. It seems to be a bug unique to my setup somewhere along the line, especially given I can’t find anyone else describing the same issue. Though I haven’t tried the Airtable community to be fair, I’ll give that a scour too.

Just to note, I’ve had this issue across different bases too.

1 Like