Maximum execution time


Is there anyway to automatically restart from where it stop when the scenario reach the maximum execution time? (40 minutes)

Hello @Bruno_Gabriel nice to meet you.

You can check your previous running of the scenario and see how many bundles did you run, and then set a filter where bundle order position is greater than previous run.

Like in this example:

Don’t hesitate to contact us if you require further assistance.


1 Like

It might be a weird solution and not at all recommended, but what you can do is utilize the Break module in every module or the module that you think is where the timeout happens.

What you want to do is enable Allow storage of Incomplete Scenario in Module settings. I haven’ personally tried this for the maximum execution time, but if it fails and is throwing an error, it should now then be logged in the Incomplete Execution tab in Exuection history from where you can then rerun the scenario, and then it will pick it up from wherever it was initially stopped at.

Like said, I am not sure if it is a right solution or if it works all together. But, Break Module is intended to be use liked that, So, Give it a try you can review error handle further here.

1 Like