Notion API bad gateway

I’ve also escalated this with Notion. It seems that you can access the DB schemas but the calls to individual pages is what is failing (either returning a timeout or a 502 Bad Gateway).

I’m still having issues. Everything was fine until I started getting the 502s about the same time others in this thread did. Once those started clearing up, I started getting 409 errors all over the place on things that worked prior of the 502s so I’m wondering if a bunch of bad data got created on some of those requests and now I’m just stuck because of it

Hello everybody @here

Thank you all for returning with your updates. I genuinely appreciate your ongoing collaboration and I am truly sorry to hear that the issue still persists.

I just wanted to quickly let you know that our dev team is in touch with Notion and that we’re trying to see what can be done about this.

I am watching this issue closely and the moment I have any fresh information, I’ll be sure to share it with you in this thread.

Thanks again for your continued involvement :pray:

9 Likes

Hello @Michaela any news concerning this issue ? :slight_smile:

Hi all,
I’ve been reading the discussion. I’m also facinf the 502 Bad Gateway error, in this case when creating a new item database item.
Is anyone else having this same issue?

Kind regards,
Oscar

image

Hello @Michael_Bastien :wave:

Unfortunately, there are no news just yet. We contacted Notion to see whether there’s anything we can do to help and address this issue and are now waiting for them to get back to us.

I will make sure to post an update here in this thread as soon as we learn anything new about this matter.

2 Likes

Hello everyone,

In addition to the 502 Bad Gateway, I have also something that prevent me from running or re-running my scenarios: it is the “timeout errors”. It has started just after the Bad Gateway errors.

As soon as a database has more than 20-30 columns, and around 100 lines, with a few formulas, it is impossible to run any scenario.

Not sure if I am the only one with this issue as well, but just wanted to share it, because probably linked to the Notion API as well.

1 Like

Has anyone been able to get their scenarios running with Notion? I’ve been trying to just access updated pages via the /v1/search/ endpoint without success - it will always timeout. I can, however, see the database schemas through the same endpoint.

nope @segleaur, same on my side. Unbelievable not to have answers from Notion support about it. :face_with_raised_eyebrow:

I have been able to make my scenarios work actually.

In my case, I noticed that the formulas triggered the timeout errors (I have quite long formulas).

So I removed the longest formulas from the database that is connected to Make, and used the Notion automations to send the datas to another database which contains the formulas (this database is not connected to Make).

I then retrieve the results of the formulas with rollup’s in the Database that is connected to Make, and it works.

This is a workaround that requires some work, but at least I can use my scenarios. So hopefully if you remove as many formulas as possible from your database, you should be able to make your scenarios work again. :slight_smile:

Hey everyone,

Good news!

Today I got a message from the Notion Support Team about this issue. The rolled out a fix to solve it.

Now we can test if the issue is resolved or not.

Happy testing!! :partying_face:

Hello everybody @here

Here’s the latest update from my end: Unfortunately, we haven’t heard from Notion just yet.

However, there seems to be a workaround by @UCM_NPO_INC and some excellent news from @budo. It’s truly great to see the community coming together :pray:

Thank you all for continuously stepping in to share your updates and findings. Your involvement and support are invaluable to us.

Fingers crossed that the fix deployed by Notion will get things up and running smoothly again. :crossed_fingers:

2 Likes

12 hours after the fix: No issues so far on my side (in my account and my customers’ accounts).

I’m still getting the timeout error for scenarios querying databases with lots of properties and formulas. :frowning:

Yes, I still have the timeout errors for the databases from which I didn’t remove many formulas.

In the meanwhile, the workaround that I mentioned earlier in this conversation works very well though. And I have just received this info from Notion today: “Our engineers are working to investigate some reports of problems with Formula 2.0 queries in our public API”

So, hopefully the timeout errors will be fixed soon, in the same way the bad gateway errors seem to have been fixed. :slight_smile:

The timeout issue is something different than the “502 bad requests” and should be addressed at Notion Support with a new ticket. Did you already open a new ticket? If not: Contact Notion Developer Support which is responsible for the API. You find them here https://developers.notion.com at section “Getting help” → “Support” → “Contact Notion developer support”

I do not get any of these timeouts. Maybe because I don’t have such complex formulas. Therefore I cannot assist solving this topic. I hope you can solve your issue soon.

Thanks @UCM_NPO_INC and @budo,

The formulas 2.0 update was very significant to the Notion architecture and I’m not surprised we’re seeing some challenges like this. I am certainly following up with them directly. Hopefully we get a resolution soon.

2 Likes

Hello everyone @here

I just wanted to let you know that the Notion team messaged us with some good news. They’ve implemented a series of changes and fixes on their end, and everything should now be back up and running.

Please go ahead and test everything out for yourselves to see. :pray:

1 Like

I am still having trouble with databases that have long or many formulas where it still times out using Make’s Watch Database option. It seems that if there are many items that have been updated since the last run, it will fail.

The only workaround, if you have a large database or lots of formulas, that I have been able to get working consistently is to do an API call to the query endpoint (/v1/database//query) with a filter like:

{
  "filter": {
    "timestamp": "last_edited_time",
    "last_edited_time": {
      "on_or_after": "{{addHours(now; -1)}}"  
    }
  }
}

And have the scenario run within the timeframe that you’ve specified. There are some caveats with this method: this method doesn’t know if the scenario has already run with the same data (so it may mean calling the same items over and over again) until the last_edited_time gets past the threshold you specify above (so it might consume more operations). It’s also not bulletproof - I will still get timeouts if I edit many items at the same time (looks like 25 might be the cutoff - but I have had it fail with a few less).

Hi @Michaela ,

Thank you very much for the follow up.

I also received a message from Notion a few days ago, mentioning that they had released certain updates, but this is the same as for @segleaur : for databases that have several formulas or more columns (40+), I still have the timeout errors if I don’t use the workaround that I described earlier in this conversation. The issue comes from the Watch database module mainly.

Notion support also told me the ticket is still in review, so hopefully there will be other improvements to come. :slight_smile: