Problem on CSV with Mail Module


I’m having unknown characters with the CSV I receive through Mail Module. Does anyone know why would this happen?

In the original CSV, there are no such unknown characters but the characters are not english.

Thank you!


Any idea anyone for this one?

Are you sure the data is correct in that csv @onurbolaca? What kind of character is it?

You can try to use the ascii() function to see if that fixes the output.

1 Like

I’m also trying to get CSV attachment through Microsoft O365 Mail and try to parse the data to be able to map each column to somewhere else.

This is what I get as data;

What is the problem here? Why I cannot get the proper data?

Hey @Bjorn.drivn ,

I think it is a mistake to merge my two topics without asking. O365 and Mail Modules are different and I was hoping to hear two different approaches for two different solutions in two different topics.

Hey @Bjorn.drivn ,

The data is correct on CSV file. It only has non-english characters. It can be opened very well with Excel.

Thank you.

Hi @onurbolaca , the module itself will not be the issue. So either you use mail, gmail, outlook etc. they all output binary or text data.

The CSV data is text data, which means that it needs to be encoded properly. Can you please show us the CSV in a text editor? Also, please try to use the ascii() functions and see what that does.

1 Like

Hey @Bjorn.drivn ,

Here is my CSV file in text;

Datum;Anfragen-ID;Anrede;Vorname;Nachname;Firma;Straße und Hausnummer;PLZ;Ort;Geo-Koordinaten des Objekts;Kontaktnummer;Zusatznummer;E-Mail;Interesse an;Worauf soll die Solaranlage installiert werden?;Ausrichtung der Fläche;Eigentumsverhältnis;Alter der Fläche;Stromverbrauch;Sonnige Fläche in qm;Sind Sie an einem Stromspeicher interessiert?;Neigung der;Art des;Sonstige Informationen
6.06.2023;;Herr;;;;Wangenblick 2;;;;15773501960;;;;Ein-/Zweifamilienhaus;Süd;Ist (Mit-)Eigentümer/in;25 bis 75 Jahre alt;2500;21;Ja;31° bis 45°;;


I tried ascii() but it didnt differ anything;

Hey again @Bjorn.drivn ,

But it worked with Mail module,

It seems like the modules are different so the reaction is also different. We needed this 2 different topics although you think we should merge them without asking my opinion or my needs :slight_smile:

Thank you for ascii