CSV character being added when splitting string


I have created a scheduled automation that will query my Airtable view, create a CSV of that view, then email the results over to some stakeholders. I have two “Contact” fields (separate field names) that are linked fields. To avoid obtaining the recordId’s, I created a Lookup field that is just the names of the contact.

My scenario then uses the Create CSV (advanced) module to map fields to CSV headers. What I’ve found is that when I send the created CSV to an email, I get weird characters (Â) in-between names after columns.


Bob Builder, Big Bird, Charlie Brown

Any thoughts on how to fix this?

HI @Devan_Kreitzer,

Are you getting that  character after the Create CSV module or is it only visible on email that you are sending?

1 Like

I am creating an email attachment using the “text” from the CSV module to fill in the attachment. Within the CSV attachment (in the email), the character is showing up.

I’m finding that the character is showing up when pointing towards the entire array when setting up the CSV mapping.

For example, the field (within Airtable) is a Lookup field. So when trying to do the mapping within the CSV module, it comes up as an . If I click just the high-level field[] there is , splitting each item in the array.

Did you have any idea on what the issue might be?

I believe the issue is how the computer interprets the CSV. I’ve tried adding the exported CSV to Dropbox and when I view the file within Dropbox there is not weird character. But, if I download the CSV from Dropbox and open it, the character is there.

Still unsure how to fix it.

Heya @Devan_Kreitzer :wave:

have you found a solution to your troubles?

If yes, could you share it with us please? This way our community stays neat and tidy and other users can easily find advice to similar issues.

Thank you! :seedling: