Saving scenario error: request entity too large

Hi all. I meet problem with make, for some reason i can’t save my scenario and got this message as report “Bad Request: request entity too large”

This is my scenario, it is quite large, can’t fit on one screen - https://i.imgur.com/CY7rqLr.png
This is error i receive when trying to save it - https://i.imgur.com/oNUVU4B.png

I contact support but not get respond yet. Any help would be greatly appreciate! Thanks.

Best,
Manojlo

Hi @Gigatron ,

its like the error states unfortunately, your scenario is too big. I have discussed this with support earlier already and it seems like the backend system currently can only support 2MB of data.

I quote the following from support:

In regards to the payload too large error please note we don’t have any limitations for the number of modules in a scenario, which means that technically, you can add as many modules as you need in order to design your ultimate workflow. However, there is a 2 MB limitation to a scenario blueprint (which is the scenario itself comprising all settings, described in our own meta-language). Once this limitation is reached, the “Payload Too Large” warning is displayed and you cannot save your scenario.

This means you have to split your scenario into multiple scenarios. You can then trigger them via HTTP and webhooks.

This is a great practice and I personally think this should always have to be done no matter what. handling these big scenarios could be a huge issue later on.

1 Like

Thank you for fast response, as you suggest I’ll split scenario. Anyway, I chose to build it huge and non-destructive in one scenario so if in the future we have any changes in the company, it’s easier to change one scenario module and automatically implement it on everything. Once again, big thank you for fast response, appreciate your help!

Best regards,
Manojlo

Hey @Gigatron ,

I understand the reason why you went for the 1 megatron scenario, however I would not say this is a best practice :wink:

You can achieve this as well when using multiple scenarios. Make sure you look at the following things for example:

  • Data stores to save and retrieve things (configurations, data records, history etc.)
  • Organization and Team variables which can hold data and to be used everywhere
  • Use the main scenario as “data handler” and “processor” then send the data which is required via HTTP to other scenarios. In this case you only need to modify the main scenario in case something changes somewhere.

Feel free to let us know how it went and what you achieved :wink:
Always interesting to see .

1 Like

This method of error handling is really unacceptable, to be honest.

Imaging spending countless hours crafting a scenario, and then when you finally hit the “Save” button, you get this “Bad Request: request entity too large” error.

It’s horrible. It forces developers to constantly hit “Save” while making incremental progress, because there is no visual feedback to show when a developer is about to hit this arbitrary 2MB limit.

Make engineers need to do better here. We shouldn’t have to craft arbitrary workarounds for this.

4 Likes

Just some extra information to check if you have this issue:

In regards to the payload too large error please note we don’t have any limitations for the number of modules in a scenario, which means that technically, you can add as many modules as you need in order to design your ultimate workflow. However, there is a 2 MB limitation to a scenario blueprint (which is the scenario itself comprising all settings, described in our own meta-language). Once this limitation is reached, the “Payload Too Large” warning is displayed and you cannot save your scenario.

Just to clarify, the mentioned 2 MB limit is not for the size of the exported blueprint file, but for the actual data in it, which can be checked by following the steps below.

  1. Add the Make Devtool extension to your Chrome browser.

  2. Open your Make scenario that is throwing the error.

  3. Press Control+Shift+I or F12 (Windows) or Command+Option+I (Mac) on your keyboard to open Chrome Developer Tools.

  4. Go to the Make tab.

  5. In the left panel, open the Tools section.

  6. In the bottom left corner, click on Get Blueprint Size.

  7. Click on the Run button.

It can happen that the size you see when following the steps above is below 2 MB, but you still see the “Payload Too Large” error. The reason is that the size of the blueprint that the scenario is trying to send to our servers when hitting the Save button can be slightly bigger, mostly due to some extra metadata. You can check how big exactly the version of the scenario that Make is trying to save is by following the steps below.

  1. Open the scenario.
  2. Open the Chrome DevTool (F12).
  3. Navigate to the Network tab.
  4. Save the scenario.
  5. Click on the item with the scenario ID in its name and find the “content-length” value - once this value is over 2 MB, the scenario cannot be saved with the “Payload Too Large” error.

In order to explain how the computation of the blueprint size works, you shall understand that each Make module has its own “weight” which is related to the way a 3rd party application provider designs their own API. The more complex the heavier. Usually, modules are very light but it seems that CRM modules use to embed a huge amount of information which makes them really heavy in regard to the aforementioned computation scheme.

Therefore, in case you are facing the “Payload Too Large” warning, we definitely recommend breaking up your scenario into multiple ones that you chain using a combination of HTTP calls, Webhooks, and potentially, Data Stores.

To sum it up - the size of your scenario is simply too big for Make to handle, therefore you need to split it into smaller chunks.

2 Likes