"Server did not recognize the value of HTTP Header SOAPAction"

Hello folks!

I’m trying to run a SOAPAction through HTTP request because it’s not possible with the SOAP module.

I’m running into this error: “Server did not recognize the value of HTTP Header SOAPAction”

My HTTP request module is set up like this:



According to the WSDL the SOAPAction “http://www.theyukicompany.com/ProcessSalesInvoices” should be a valid action.

Why do I keep getting this error?

Thanks!
David

Hi @Davidof90,

I also have a SOAP integration with another SOAP API and my configuration looks a little bit different.


According to your screenshots:

  1. I would remove the headers
  2. Change Content type to Custom
  3. Set the value of the Content type to text/xml
  4. Remove everything before your opening soap tag

Please try this and if it does not work, share screenshots of the most recent configuration and error message.

Glenn - Callinetic

1 Like

Thanks!

I tried your settings, I’m getting a different output (empty body):

My module is set up like this:


This is the XML I tried to import:

And this is the XSD.

Thanks!

I’d like to add this: When I call the same webservice with the SOAP module, I have a better view of the required variables:

Guess I’m almost there, I’m running into some XML issues now.:

I added a “create XML” module so it would be better structured, I validated it with the XSD. But still getting empty body result:

What is the complete request body?


And this is inside (I validated it with the XSD)

I also tried with Postman but same result.