SOAP and HTTP walk around- Poland GUS service


I have problem with access to GUS REGON service- it is a polish government database of companies and their registration data.

When I try to access it with SOAP module I receive constant error:

Unknown namespace q1

And I think problem is under WSDL because of


That’s why according to Make’s official support page I tried walkaround with HTTP module.

When doing it exactly as instruction:

Body type: raw
Content type: application/xml

I receive status code 415 with error:

cannot process the message because the content type “application/xml” was not the expected type 'multipart/related;

So I tried different combination of content types. All of them with the same results- except one:


And received status 500.

But that’s still not success.

They are using SOAP protocol- documentation available here- Portal API GUS

Sandbox for testing:


Sevice URL:

User key (KluczUzytkownika)


How does it work. You need to send request with envelope Zaloguj and you will receive token valid for 60 minutes, 20 characters long.

XML which I used:

<Envelope xmlns="">
        <Zaloguj xmlns="http://CIS/BIR/PUBL/2014/07">


<?xml version="1.0"?>
<Envelope xmlns="">
        <Zaloguj xmlns="http://CIS/BIR/PUBL/2014/07">

Do you have any ideas what can I try? Or it will be impossible to connect GUS REGON with

I don’t have any experience with SOAP. I know that is existed but was using it only for last 6 hours to try different options and XMLs.

Have a great day!

This needs an expert’s investigation, create a support ticket.

Thank you for reply!

I spend more time to check different options and found request body that works.

Maybe not as it should but at least generates 200 respond.



XML Body:


But still- isn’t recognising respond body as XML.

How it looks like:

How it should look like:


Should contain 20 characters key.

Binary (hexadecimal) code generated by Make contains:

Content-ID: <>

Is there any module or option to extrude all 650 bytes to have this key?

Have a nice day!

Hi Michass,
Have you managed to make a connection to GUS?
I have same problem. :frowning: