SOLVED (SORT OF): Wordpress connection timing out

I have a number of scenarios connected to two WordPress websites via the Make plugin in WordPress. Since some time last night this module has been timing out. I tested the connections this morning and they do not verify.

According to my hosting provider there are no problems their end.

Any ideas?

Hi Stu. Can you post screenshots of the exact errors you’re seeing (in Scenario and when verifying)?


Those are from two different scenarios, and when pressing the ‘verify’ button.

this most of time resolve the this recommended php.ini settings in your server side are:


if you have been trouble Expert Help
Most of the time troubleshoot and resolve the problem you can follow these steps :

  1. Check API Endpoint: Ensure that the API endpoint URLs for the two WordPress websites are correct and haven’t been changed unintentionally. Verify that the endpoints are reachable and accessible.
  2. Verify API Credentials: Double-check the API credentials used for the connections. Make sure the credentials are accurate, up-to-date, and have the necessary permissions to access the WordPress websites.
  3. Test with Different Credentials: If possible, try using different API credentials or generating new ones to see if the issue is related to specific credentials.
  4. Check Plugin Version and Compatibility: Verify that the Make plugin is updated to the latest version and is compatible with the WordPress version you are using. Outdated or incompatible plugins can cause issues.
  5. Check for Server Limitations: Some hosting providers may have limitations on the number of API requests or connections allowed. Check with your hosting provider to ensure there are no restrictions affecting your scenarios.
  6. Review Logs and Error Messages: Check the logs and error messages in the Make plugin or WordPress admin panel to see if there are any specific error codes or messages that can provide clues about the problem.
    Best Regards

@Pro_Tanvee I’m not sure about that … the ModuleTimeoutError is coming from Make, due to not receiving any response from the API endpoint within a given time. It’s not an error from WordPress.

The best way to confirm whether it’s a problem in Make or a problem with your hosting provider is to try using Postman to access your WordPress instance.

Try running a Postman GET request against https://<yoursite>/wp-json/wp/v2/users/me with a Header line of iwc-api-key: <yourAPIkey> and let us know what you get.


Update. My FTP connection is also broken so I’m pretty sure this is a problem with my hosting. Onto support with them right now.

Ooof… ok I created a postman account but not sure where to go next!

EDIT: Yup. Completely lost here. Help! :sweat_smile:

I am already said problem coming from PHP server side.

I’ve fixed the FTP issue by using the hosting provider’s generic FTP address, rather than my site specific one. I have no idea why that’s worked.

The Wordpress API connection is still falling. Waiting on more updates from support.

1 Like

You may be able to use this Postman Collection link that I just set up.

You’ll need to set the {{YourWordPressSite}} and {{YourAPIKey}} variables in the URL and the Headers respectively. Or just replace them with your values.

If this Postman operation also times out, then it’s a 99% chance that it’s an issue with your hosting provider.


I’m so sorry… I still don’t understand what I need to do! :sweat_smile:

I can’t see those variables in the URL and when I try to change them on the site I can’t… buttons are greyed out.

I’d thought Postman would be the easy route, but it seems not :person_shrugging: That’s not on you … it’s on me!

Hoppscotch is way simpler.

Go there and next to GET in the URL bar enter https://<yoursite>/wp-json/wp/v2/users/me (replacing as appropriate).

On the Authorization tab select API key.

Set Key as iwc-api-key and Value as your API Key from the Make WordPress plugin. Set Pass by to be Headers.

Then click the Send button and see what happens.

1 Like

Haha. I’m particularly useless in many cases!

In this case, the problem has suddenly fixed itself… I was away for a bit and when I came back it was all working again. :grimacing:

UPDATE: Couldn’t get to the bottom of it. Went and did something else. Came back an hour later and it’s working fine again! :sweat_smile:


Looks very much like an issue at your hosting provider … glad to hear it’s all sorted!


Yeah… weird one. Had me worried! Thanks so much for your help!

1 Like