The operation failed with an error. 403: PERMISSION_DENIED - The caller does not have permission

Hi, done authorizing and verifying, but it still wouldn’t push through. Would appreciate any help. Thanks
Beginner here.

Did you enable the Google Sheets API for your custom Google Cloud project?

Basically do this, but also enable the Google Sheets API:

Try deleting your current connection and set a new one up with your custom Google Cloud project, that has Google Drive/Sheets API enabled.


Thanks, @samliew! It’s working now.

No problem, glad I could help!

In future, please create a new thread for each question. This makes it easier for others with the same problem to search for the answer. Thank you for your cooperation!

The Make Community guidelines encourages users to try to mark helpful replies as solutions to help keep the Community organized.

This marks the topic as solved, so that:

  • others can save time when catching up with the latest activity here, and
  • allows others to quickly jump to the solution if they come across the same problem

To do this, simply click the checkbox at the bottom of the post that answers your question: