Trello modules not pulling in correct data

I’m new to Make as of earlier today and trying to move my Zap over to Make, but I’m having a little difficulty, particularly with the Make’s Get a Card module for Trello.

My workflow is simply this:

  • Watch cards in the Requested Items list of my Amazon Vine Trello board
  • When a new card is added to Requested Items list, get the relevant data and create a new row in the Amazon Vine Google Sheet.

Pretty simple, right?

So in moving from Zap to Make, I learned I had to create an intermediary step, using the Trello Get A Card module so that I had access to all the fields I need to insert into Sheets. Without the Get A Card module in the middle, the scenario would work and pull in the correct data, though I didn’t have all the fields I needed.

After I inserted the Trello Get A Card module in the middle between Trello and Sheets, there’s now a disconnect, and the Get A Card module is pulling in random data from other lists in my Trello board instead of confining itself to the Requested Items list as initially specified. Adding the “man in the middle” somehow broke the flow. :frowning:

I’m sure it’s something I’m doing wrong. I thought I was getting the proper card ID over from module 1 to module 2. Here’s what stuff looks like:

Unfortunately, I can’t get the popup to stay up on the screen when taking a screenshot, but in the last image I’m mapping to Sheets from the Trello Get A Card section, which as I said is not restricting itself to just the single Requested Items list like I want.

Can anyone help me figure out what’s going on?

PS - my first post here too so please forgive any formatting issues with uploading screenshots. I’ll try to fix up any foobars after. :slight_smile:

To resolve this issue, follow these steps:
Confirm Mapping: Double-check the mapping in the Trello Get A Card module. Ensure that you are correctly mapping the Requested Items list as the source for retrieving card data. Verify that all the required fields are properly mapped to their corresponding fields in the Google Sheet.
Filter Cards by List: Add a Filter module after the Trello Get A Card module. In the Filter module, set the criteria to include only cards from the Requested Items list. This will ensure that only cards from the desired list are passed on to the next step.
Connect Filtered Data to Google Sheets: After filtering the cards, connect the filtered data to the module responsible for creating new rows in the Google Sheet. This will ensure that only the relevant data from the Requested Items list is inserted into the sheet.

If you continue to experience difficulties or need further assistance, please let us know, and we’ll be happy to help you troubleshoot the problem.
Best Regards


Hi Pro_Tanvee! Thanks for the reply.

Unfortunately, the only mapping available in the Trello Get A Card module is the Card ID field as per the image above. And I am pulling that from the previous step’s Watch Cards data. (Not sure if I’m using the right terminology here, but I assume you catch my drift.)

I also created the filter after Trello Get A Card module, but it’s still not pulling in the new data. It’s just skipping over some of the old stuff that it would’ve otherwise pulled in.

So I decided to go back to the basics and created a new scenario using only the Trello Watch Cards and Google Add a Row modules, taking out the Trello Get A Card module for now. (Doing so leaves out a lot of the fields I need, but doing it now for the sake of testing.) But still no go! Even the Watched Cards module is pulling in old data instead of the card I just added to the list. (So perhaps I should update the subject of this post to reflect that. I did think I had that working with just the 2 modules at the start but I guess not.) I don’t know if setting up a webhook would help here either, but I figured that would be for down the road once I got it pulling in the correct data just via the 15 minute schedule.

Anyhoo, I’m generally a pretty smart cookie, but for the life of me, and after spending all day with it, I still can’t figure out what’s going on. Perhaps I’m misunderstanding how the Trello modules are supposed to work? I had assumed that if I told it to watch a particular list for new cards, then only those new cards would be part of the incoming data set. Am I correct in that assumption? Because that’s not what it’s doing unfortunately. :frowning:

I just tried something else different… rather than using the Watch Cards, I tried a different scenario with Trello’s Watch Cards Moved to a List instead. Ran that with a single data execution and what I get is a card that currently resides in the Done list. Yet if I look at the raw data that the Watch Cards Moved to List module pulled in, it shows some of it’s old history. It started life in the Searches list, then moved to Requested Items. (which is what it shows in the data below.) But after that it moved into the To Review list, and then finally to the Done list… so in the case of this module at least, if the card ever spent any time in the Requested Items list (as most of them have at the first stage), then it’s a candidate for being part of the data set.

I really just need to work with the stuff that’s in that list now, and specifically the stuff I add from this point forward as I already have my Google Sheet populated with the previous data from doing all this with Zapier previously.

1 Like

So I’ve got the “basics” working again, with just a Trello Watch Cards module and a Google Add A Row module, by creating a new scenario from scratch. The data it’s pulling in is only newly added cards on the Requested Items list.

I’m going to try to add the Trello Get A Card module back in the middle again and see if that breaks things. I’m fairly certain that’s what happened the first time around, but I may have to finish work on this tomorrow as it’s getting pretty late here. I just wanted to get a note out here that Watch Cards seems to be pulling in just the newly added data to that list again once I set everything up again from scratch.

Well whaddaya know! Having created this scenario again from scratch it’s now working as intended, even with all 3 modules back in place: Trello Watch Cards, Trello Get A Card, and Google Sheets Add a Row. :+1: I configured everything the exact same as the first time so all I can figure is something somehow got out of whack in the first iteration and nothing I tried was fixing it. Now it’s all working as intended.

Thanks again for your willingness to help me out on this @Pro_Tanvee .

Hello there @CheriePie welcome to the Make Community :wave:

It’s great to hear that you managed to get this up and running :clap: It’s funny how sometimes things just click, even when we’ve been doing them the same way before, right?

Anyway, thanks so much for jumping back in here and sharing your progress as well as the solution with the community. It means a lot to us. :pray:

Keep up the great work!

1 Like