Webhook pulls data in, but certain data doesn't update in Google Sheet

Any Make legends out there able to trouble shoot this issue. My scenario pulls data in on a webhook and updates a Google Sheet row. The webhook pulls the data in - all the data appears in the webhook bundle.

When I map the fields into the Google Sheet row, the email data doesn’t appear.

So - It comes in on the webhook, but for some reason isn’t passed over into the Google Sheet. I attach screenshots below of the Webhook bundle. Then the mapping of the field into the Google Sheet. As you can see, the email data isn’t bought over.


Screenshot 2023-05-22 at 9.59.05 AM

Hi @philparkinson,

I faced similar issues in the past.

It is one of the weirdest bugs or not sure if it is intended to be that way, the problem is due to array indexing present in the Email i.e [0], and I am not sure if there is a straightforward way to solve this.

How I solved it way by Editing the Webhook and enabling the JSON pass-through.

And, After this, I setup a Parse JSON module, and replaced the index characters i.e [0] with empty,

Screenshot from 2023-05-22 22-18-21

It fixed the issue for me, Not sure if there is a better way to do this though.

1 Like

Firstly, thank you very much for taking the time to reply. I tried your method, but it broke the scenario. (I’m a non-techie, so I probably did something wrong). I set it up like this.

And I got all this error message in the parser.

If you know what I did wrong, or what I can do to correct, I’m all ears. I’m gonna contact Make HQ now and if they reply with a solution, I’ll come back on here and post it.

Once, you have enabled the JSON pass through, the value email[0] or something in your module will not be accessible instead it will be value that will basically be a JSON string of your webhook, which then needs to be parsed in Parse JSON module to be able to use in other module.

1 Like