Why is this scenario not triggering?

Hi all,

I’m relatively new to Make and struggling to figure out why a scenario I’ve built is not triggering.

I’m including a screenshot of the scenario below. For now I’m just focusing on the top filter as highlighted (called “Tarpaflex products” in the screenshot).

The aim is as follows:

  • Shopify module watches for new orders
  • Router splits the flow down 4 paths
  • “Tarpaflex products” filter checks to see if Shopify SKU matches with a predefined list of SKUs
  • If there is a match then a task is created in Asana and a purchase order raised in Xero
  • If there is no match via the first path, then the router moves to the second path (with filter “M&N Canvas OTS Products”)
  • If there is no match via the second path then the router moves to the third path (with filter “PGS Supplies OTS Products”
  • Note the fourth path is disabled as it’s only there for testing.
  • This scenario runs once an hour, so it is likely there are approx 20 new orders each time the scenario runs, and it’s likely approx 5 of these orders will match one of the three paths described above. As such, we’d expect 5 new tasks in Asana, and 5 new purchase orders in Xero.

This isn’t happening. Here’s more detail of all the settings…

First we have our Shopify module which is looking out for new orders. Status, Financial Status and Fulfilment Status are all currently set to “Any” to ensure that absolutely ALL orders are coming through.

We then have a router with 3 paths stemming from it. There are filters on each path. Here’s the filter on the first path, called “Tarpaflex products”

As you’ll see, we’re filtering based on the Shopify line item SKU, as long as the SKU contains a certain text such as:

  • or TRPWMD
  • or TRPGWS
  • And so on…

And this is where things seem to be going wrong. Here’s a screenshot of an order from our Shopify store from yesterday…

The SKU contains TRPGWS. As far as I can tell, this order SHOULD have been picked up and filtered via the “Tarpaflex products” path. This hasn’t happened. Nothing has been filtered, no task has been added to Asana and no purchase order set up in Xero.
There are no errors in Make history. The filter simply isn’t detecting the order.

I’m not sure if the router might be causing issues here? I’ve previously had issues with routers not functioning as I expected them to.

Just wondering if anyone has any suggestions here?

I’ve tried adjusting the filters on the “Tarpaflex products” path to “Text operators: Starts with” rather than contains and updated the text to B-TRPGWS to match exactly with the start of the Shopify SKU. Really not sure this will help though.

Hi @DK1,

Is there multiple line items for the given product? Try using this instead and see if that works,


And, In filter basically do if the above contains B-TRPGWS.


Hi Runcorn, thanks for the reply.

Orders CAN contain multiple line items yes, but in this case there was only 1 line item on the order.

Thank you for the recommendation though. I’ll add this because I assume it will help if there are multiple line items on future orders. But I’m not sure if this resolves the current issue given that this specific order only contains 1 line item?

Can you share me a screenshot of how the SKU looks like in the Shopify Line Items?

1 Like

Hey @Runcorn

Sure, here’s a screenshot of an example order from Make (the SKU on this order will not match any filter)

And here’s a screenshot of the same order in Shopify…

I have a question about this actually. In your example above, you have typed “sku” as text. Is this correct, as below…

Or should the SKU variable be from Shopify? Like this…

Thanks again for your input :pray:

That should be text, so it will be sku and the Line Items Mapping is fine. So, The first screenshot looks good.

1 Like

Thanks, just going to run some tests based on this now.

Unfortunately still not working. Just put a test order through with SKU B-TRPGWS-3.5X3.5-1 and the filter hasn’t picked it up.

I’m slightly confused as to why every time this scenario runs, Shopify keeps picking up the same operation (an order from June 19). We receive 30-40 orders a day, so not sure why it keeps falling back on this specific order. See screengrab below.

I’ve also just tried increasing the limit on the Shopify module to 10 but this doesn’t seem to make any difference either.

Still at a loss. If anyone has any suggestions they would be gladly received!

To fix that you can right-click the Watch Modules and then Choose Where to Start, over there set now and save the sceanrio.

After that see if that fixes the filter issue that you are getting?

1 Like

Hey Runcorn, thank you so much for all your help. I’m still testing but it looks like it might be working.

I’ve run into another issue now though. When creating the purchase order in Xero, I’m getting an error “A validation exception occurred (10, ValidationException) The UnitAmount field is mandatory.”

I understand the error. Unit Amount has intentionally been left blank because the cost data (the price it costs us to buy the item from the supplier) is stored in Xero against the corresponding SKU.

Our cost price data is not currently stored in Shopify, only in Xero.
Is there any way around this?
One option may be to move our cost prices to Shopify by adding them to the Cost per item field as shown here…

The problem is I cannot see the cost per item variable in the Shopify API.

Any idea what I can do here?

For the cost I believe a good way to handle this would be to look-up your items from xero before you create your invoice and then map the item lookup result into your invoice.