Xero Journal API

I am trying to make an API call via the Xero’s API module in Make. However, it returned a 403 unathorised error. I think it is because the specific access is not requested before.

This is the API call that I am trying to make Accounting API Journals — Xero Developer. None of the standard Xero modules do something similar.

How do I go about adding more authorisation?


Hi @Backbone,

Welcome to the community!

I have used the standard Xero modules in Make to access and create manual journals in Xero.

Please could you tell us what you are trying to do that cannot be done in the standard Xero modules.

And please include a screenshot of how you’ve configured your “Make an API Call” module to help the community to give you better answers.



Hi @Terry_Hopper

To be honest, I am not sure if this is the right API to use. What I am trying to do is to extract the whole ledger out of Xero. So the manual journal modules ain’t useful because if I understand correctly it only extract the manual journals and not the others.

Hi @Backbone ,

Thanks for attaching screenshots.

You’re right, the only way to access all items on the ledger, is to individually call all the different endpoints, so Invoices, Credit Notes, Bank Transactions, Manual Journals etc.

However, if it is just summary information at account level you need, the Reports endpoint may be a good place to look.

Are there specific transactions you’re looking for? What is your use case?


I am looking at extracting all the transactions of a GL account and saving that to an Excel file. Have you tried Journals endpoint before? I believe what I am missing is the access. I am not sure how to add additional authorisation for Xero.


Hi @Backbone ,

Sorry, I think I was wrong in my last message. I have just tried the Journals end-point for the first time. I can only imagine this is a new end-point, because we never used to be able to do this before. That would also explain why authorisation is not included in the scopes of our existing Xero connections.

On the first try, I did get the same error message as you.

To create a connection with the correct authorisation, I then created a new Xero connection, clicked the “Advanced” button, and then selected the scopes I needed, making sure to include Journals:

If this solves your issue too, then please mark this message as the “Solution”.