[Airtable] Search Records module returns multiple bundles, but I can only link to one?


I have an Integromat scenario in which I am pulling three of the latest airtable records (sorted by created time, limited to 3), and I get the following output (success):

Three bundles as expected, yet when I go to reference the data from these three bundles in a later module, I can only see the first. See here:

How can I access the data from Bundles 2 & 3, if only data from Bundle 1 is shown?


Hi @olivedrab ,

That’s how bundles work. When you have a module that outputs multiple bundles, each bundle is processed individually.

However, you could aggregate those bundles into one array. Therefore, you could use an array aggregator.


This module will output an array with the content of the three bundles. To access the right index in the array, you could then use the get() function. Keep in mind that the index in Make starts with 1 and not with 0.
I hope it answers your question.
Glenn - Callinetic


Hey Glenn, thanks for pointing me in the right direction!

I am trying to figure out the get() function, but someone recommended a map() function as well. What is the difference?

Thanks again!

PS— I got it. Thanks for pointing me in the right direction. I learned about how to map arrays here.

Hi @olivedrab,

Good to read that you’re making progress. Is your issue solved or do you still need help with the get() function?

Glenn - Callinetic

1 Like

It is solved thanks again Glenn !

1 Like