[BUG?] Filter with more then 2 parameters doesn't work?

Hey my frenz

Im trying to filter utilizing more then 1 parameter but I think Im doing some wrong or I find a bug.

I tried:
1- Inserting the parameter in the same string and utilizing “or” operator and I dont achieve success with this:

2- Inserting the parameter in different “clusters” and I dont achieve success with this too, example:

When I put just one filter, everything go well…

I really need know if someone can help me


You can’t use the OR operator like that in a string input.

You can either

  • convert it to an array, and use an array filter operator, or

  • convert it to a pattern, and use a string patten does not match filter operator

If you need further assistance, please provide the following:

Please export the scenario blueprint file to allow others to view the mappings and settings. At the bottom of the scenario editor, you can click on the three dots to find the Export Blueprint menu item.

(Note: Exporting your scenario will not include private information or keys to your connections)


hi @Tiago_Morelli,
Another thing to keep in mind is the difference between OR and AND operators. In the second option you filter on: does not contain price_tag1 OR does not contain price_tag2. If either one of these statements is TRUE the bundle will pass. This means that all bundles will pass your filter. If you have a price_tag1 it will pass because of the second part of the filter. If you have price_tag2 it will pass because of the first part of the filter. So if you only want to select the bundles that are not price_tag1 OR price_tag2, you have to use the AND operator. Then each bundle must pass both parts of the filter: price_tag1 will fail for the second part and price_tag2 will fail for the first part.
Hope this makes sense :slight_smile: