Bug in Notion integration : update database item with dynamic database fails (where manual version works)

I hit a bug where using on or the other of the two Notion “update a database item” option does work, the other works:

When specifying a dynamic table, with the same value as the non-dynamic one, the request fails with a long kind of “syntax error” message.

Specifying the same table by hand in the non-dynamic one makes the request pass.

I notice the request differs just by a key (“page ID” instead of “database item ID”).

I suggest the integration should be fixed, putting the correct key in the dynamic request.
Here are screenshots to make this clear:



Hi @Micmo,

I think someone from the Make team here in the community can raise a ticket or you can create a support ticket for this.

But, to resolve the issue in hand, Can you try using select from the list instead and Map the Database ID there instead of using Enter Manually and see if that resolves the issue you are getting? I don’t have access to Notion so not sure if this works though.

That could work but there is no “Map” option when you use the “Select from the List” option.

For my use case it’s ok because the database is not dynamic, but it should work though.

Heya folks :wave:

I just wanted to step in and say thanks a lot for bringing this issue to the community @Micmo.

@Runcorn is completely right in here. The best way to report a bug at this moment is to open a support ticket with us. Thanks to that, the team can properly investigate and potentially escalate the issue.


Ok thanks, posted a ticket with a link to this post. Hope it can get fixed soon.

1 Like

I have been trying to solve the same problem. I think the solution is to add at least one field with the Value Type ‘Title’. That’s the name of the new database entry page. It’s required by Notion’s API but it’s not obvious you need to add it from the dynamic creation widget in Make. This screenshot shows a setting that worked for me.

1 Like

Hi, interesting!

Turns out I solved my issue with the help of support (so good thing to post the solution here): Changing value type to “Rich text” fixes the issue.

Seems like using Title works too then!

1 Like

Hello @mstibbe welcome to the community and thanks a lot for stepping in and letting us know what did the trick for you!

Also, thanks so much for sharing the solution you got from the support team @Micmo!

This is super valuable stuff and we all 100% appreciate it :pray: