ChatGPT to bring a response back and send it to Slack

Here is the workflow:

I’m not getting a response back from ChatGPT.

What am I missing?

See images below:


OpenAI Module


Thanks for help.

Is no one else using ChatGPT here?

Save the scenario, reopen it, run it once and than you should see the values. Seems like a frontend issue.

I jsut tried that and this is what I got.

It’s really weird, all the other automation is working. It’s grabbing the files, and sending those in the message but there’s no content coming back.


For some reason it’s not returning the response.
Am I supposed to use another module or something to pull the response before sending it to slack?

I don’t get it.

ok this is strange. Can you share the blueprint or open a ticket with our support please?

Hey @Matt_Hernandez

You are missing system role in GPT module. System role is necessary and it is an attitude to perceive for the openAI. Please pass this message in system role and I also don’t see any dynamic input mapped. Are you running it constatntly always???

Msquare Automation - Gold Partner of Make

Free Consultation | Live Implementation

Visit us here | Youtube Channel

Here’s the BP
blueprint.json (96.8 KB)

Do you want me to also open a ticket?

Hi There,

Ok I changed to System role, tried it and still nothing. It runs every 2 hrs normally and works great for everything else. I am testing this by clicking the button to “Run Once.”

What do you mean by dynamic input mapped? Do you mean this below:
I used the following to grab the data but maybe that’s the issue??? How should it look?
#17 is what doesn’t give me anything.

It doesn’t look like you are getting any output from ChatGPT. There should be a value in ‘Result’ - Run the module individually and ensure that you get a value in result.

I’m not sure what the problem is. However, I imported you bliueprint, tried to run it and had the same problem. I added a Claude module instead and it worked.


I deleted your ChatGPT module, added a new one…

And it worked.

Try that?



BTW, I didn’t ned a uaser, assistant, or anything. I added a new ChatGPT module, used the defaults and used your prompt and it worked.


It worked!! Unbelievable it delayed me this long and cause so much pain lol …

I did sent it from the “system” role.

Who knows why but deleting it and re-adding it worked.

Thanks :pray:


I suspect there’s something in the blueprint that comes from previous iterations of the module in your scenario. You might want to export your new blueprint and compare them or send them to support to review and understand the problem.

It could be a bug.