Error Processing

How can I prevent Make / Integromat rerunning a scenario after it has stopped due to a connection error?

I’m looking for a global setting as opposed to adding error handlers to every module!


If a Scenario runs, but stops because of an error, it shouldn’t retry unless you add error handling to the module having the error.

In the Scenario settings, you can also toggle off “Allow storing of Incomplete Executions”.

Hope that helps!


Hi Donald,

Looking at the docs here:

it says that following a connection error “Make then repeatedly attempts to rerun the scenario at increasing time intervals. If all attempts fail, Make deactivates the scenario.”

I’m looking to disable this behaivour.


Ah, I see now! That only applies to the first scenario, so I would say if you want to avoid Make automatically re-running the Scenario when the trigger module fails with a connection error, you’d need to add an error handler route to the trigger module and handle it accordingly.

Use a Rollback if you want the scenario to stop with an error or use a Commit to stop and mark as a success.

Use other modules on the error route if you want the scenario to send you some sort of feedback outside of Make to let you know the scenario has failed.


Unfortunately not, the bit I quoted is from underneath and applies to any modules not just the first. The only workaround I can find is to add error handlers to every module (which is a bit impractical).

My mistake! Now I am intrigued, wondering how others handle this.

What if you “Allow storing of Incomplete Executions”, then add a filter after the first module to proceed with the Scenario only if it is NOT an incomplete execution?



That looks like it might work. I was hoping there would just be a setting to disable this though!

Issue is with some scenarios re-running multiple times can have undesired effects, especially if the scenario calls another one using a webhook.

I’ve opened a support query with Make so will update here if they have any solutions.