Excel 401 error

Hello! I’ve been using Make for a while now. I’m trying to switch from Google to Microsoft, and I can’t seem to read or write to an excel file. My microsoft connection is working fine, I’m able to get docx/excel files, but whenever I try to write or read from an excel sheet, I get a 401 error. I’ve read a couple threads, but none seem to be helpful regarding this.


image

Welcome to the Make community!

“you do not have permissions to open this file in the browser”

The most likely cause is the sharing settings for the Excel file might not allow you to access the file. Do you own it or was it shared with you?

2 Likes

Thanks!

And yes, I created it today :sweat_smile:

I found the issue.

According to Zapier Staff ken.a on the Zapier forums,

Our Support Team created a bug report regarding the “You do not have permission to open this file in the browser” error. Our team is aware of the issue and is working on a fix. I’ve added your email address as another affected user. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of users affected by this issue so we can let you know as soon as we have any updates.

I appreciate your patience and understanding.

This appears to be something has changed on Microsoft’s end, and any integration needs to be updated to connect to the resource.

For technical issues or bugs like this, directly contacting Make support can often lead to a faster resolution.

You can open a new ticket, or if you are unable to login for some reason, you also can reach support using the contact form on the website.

3 Likes

I’m on it, thank you very much :heart:

Can you please explain to me what do you mean by “any integration needs to be updated” ?
reautjorizing the connection won’t work.

This means that any module code that connects to the third-party service are broken, because they are outdated.

Only support can further investigate this issue.

2 Likes

Hi, I am having the same issue. Worked fine then when I tried today 401 error.

Any update on this? Is it something make need to correct ? all my scenarios require excel

Thanks

Is This something Make or Microsoft need to resolve?

Hello @Richard3 welcome to the Make Community :wave:

As mentioned in @samliew 's helpful comment marked as the answer to this thread, it seems this issue needs attention on our end.

For further assistance and deeper investigation, please open a ticket with us. The support team is equipped with the right tools to examine this and to potentially escalate it to our developers.

Thank you :pray:

1 Like

I tried opening a ticket but they just told me to go to Microsoft, this is clearly something make need to update but i just got pushed away. i have 500k tokens just waiting to expire, i really need to run these scenarios, excel connection is really needed for me.

Hello again everyone @here

I just wanted to quickly let you know that we informed our development team about the issue and they will investigate it as soon as they can.

I will make sure to post any information I learn about I get in this thread. If you prefer to receive updates in your inbox, please open a ticket with us and our support team will let you know as soon as there’s any news.

Thank you for your patience and understanding :pray:

1 Like